Is my RAMPS board faulty?


I hooked up my RAMPS 1.4 to my 3d printer, and got everything to work except the x and y axis motors. When I try and rotate them on repetier, they make a loud sound and stutter and then move a little bit very very roughly. but when I make my Z motor turn, again through repetier, it works perfectly, smoothly and without any sound.

I tested all the drivers, and all of them worked. next I tried exchanging the the y axis motor with the z motor. this time, the y motor worked perfectly, while the z motor made the same noise and hardly moved. This test means that there's nothing wrong with my motors. Is this board faulty or are there solutions to fix this?

Thanks a lot, mitch.


  • check if all jumpers are correct?
  • yes all the jumpers are on in the right places. what could be the problem?
  • Remove drivers and check schematics ( -> ramps 1.4). Check if the 4 output pins for motor current connect correctly to the 4 pins where you put motor in or if there is a short. Since you swapped drivers and motors to test each working fine it seems logical that the driver output gets corrupted by bad or shorted contacts.

    Other reason might be wrong speed settings. Try with very low speeds to rule out high acceleration/stepper rate/jerk prevent motors from starting.
  • Hi, I'm sorry, but i'm completely new to this, can please you tell me in steps how to Check if the 4 output pins for motor current connect correctly to the 4 pins where you put motor in or if there is a short. Also where I edit the firmware to change the speed, acceleration/stepper rate/ and jerk? Sorry if my questions have quite simple answer, but as I said I dont know anything about ramps.
    Thanks, regards Mitch
  • Checking pins is easy with a voltmeter that measures for shorts or resistance. Unpluck board from any power and remove sockets. Identify the 4 socket pins that are 1a 1b 2a 2b marked in schematics or on stepper driver. These are connected directly with the 4 motor pins. Each of the pins should go to exactly 1 pin of motor connector. If none or 2 have a connection to a single pin that would be your problem.

    acceleration/jerk can be seen and changed in host/server eeprom editor. Jerk 20 and acceleration 1000 are normally no problem. Most can have more but then printer shakes more which you might see in the print as vibration marks.

    If steps per mm are wrong you acceleration might be much higher. If you have added all jumpers you have 1/16 substepping and resolution is normally 80-100 steps per mm, but that my be different depending on printer/driver.
  • Hi, this is really helpful, but  If none or 2 have a connection to a single pin, what can I do to fix this? Do I need a new RAMPS? Also, what is feedrate mean. On marlin, it says "max feedrate" and in brackets "mm/sec". what do these values mean?
  • This is the repetier-firmware list not marlin! mm/sec is the unit of the speed so you know that it is not mm/min which is used in F gcode parameter.

    If you find a faulty connection you can repair your board with a solder iron or buy a new one. It is normally just some solderings touching or not connecting. Between these lines there is no electronics just a 1:1 connection to be able to connect to motor.
  • Thanks a lot, the problem was , like you said, an acceleration/jerk issue. I fixed it and it's working fine. There's just one more problem, the motors only move in one direction and not the other when controlled through repetier. What could be the problem?
  • endstops working/correctly wired? try M119 with endstops activated/deactivated for status
  • Hi, I'm not using endstops, but I've inserted the dimensions of my printer, and the park position of the X, Y, Z axis. How can I solve this?
  • edited September 2016
    I think if they are defined in the firmware, but not seen/installed it  won't move properly.
  • where in the firmware do I make changes? And what do i chamge?
  • In config tools->mechanics select "Not installed" for endstops. Then buy endstops and install them - a printe rwithout endstops is just a pain since position is never correct. 0,0,0 is where you enable it and slicers etc. always insert homing to assert correct positioning.
Sign In or Register to comment.