BLtouch whit RADDS and repetier firmware

I've just connected up a BLtouch sensor to my RADDS controller. It works fine when I activate this with "M340 P0 s700". I have inserted the start script and stop script under z probing in firmware (configuration.h) But when I'll take a G28 is not activated. Anyone know what I need to do to get this to work?


  • You need dev version and there you must set z min pin for homing as well as z probe pin to the signal. This tells firmware that you want to home with z probe for z. You might need to use the homeing ordering with temperature (set temp. 0 to not heat during homing). Then you can say where to z probe so the position is reachable since activating z probe moves from nozzle to z probe position.
  • Hi,

    After reviewing all topic about BLTouch here on forum I still didnt manage to score a success with my setup. 

    I've got all connected up like shown on picture below..

    I have Bltouch, otherwise connected to the pin 39, but basically it works (with m340), I also in configuration.h entered all necessary settings (start and stop script, and set all on zmin)

    Since this was not working, I tried connected and change settings at the max z also not working. 

    Because I want to start auto-leveling bed to start in the middle of heated be , I used a home order xy preheat then with z and set x and y for to center, but it does not take into account.

    I am posting a link to a video of failed autobed leveling and also configurate.h file for some help.

    Please I asking for any help because I do not know what to do next ...

  • cant watch video,  says it is private 
  • edited February 2017
    Video fixed, any information of possible solution...
  • First check M119 to show H when triggered and L when not triggered for both z-min and z-probe. In video it looked like triggering did not stop z move, so that might be wrong configured. If that probe was the one only going high for a short time it of course gets difficult to test.
  • I tried to check with M119 and if I use endstop (mechanical) it works; H when triggered and L when not triggered. 

    But then when the Bltouch is connected (on the same pin the same way) it just stay L all the time. 

    I tried to connected on ZMAX pin and it is the same thing not working... 

  • So I guess I'm right that it only switches for a few ms and then goes low again. Should be no problem as moves stop directly when signal is triggered and having 2 steps within triggering period should be no problem. But video showed it a bit unreliable which is bad. But others are using it so why? Have you tried setting pullup off (electroncal endswitch for endstop configration). If on that might reduce signal time.
  • At this point i must doing something wrong, because i tried to set up in the configuration.h many different setting for zmin and then the same settings for zmax (when i tried to switch between them).

    Settings the endstop configuration for electrical endstop and switching pullup on and off seems to do nothing...even with help of post of user Slowmo (BLTouch von Antclabs) and luke321 (BLTouch Configuration on Makergear M2 with Rambo) whom obviously works...

    As i said before testing with regular endstop works great (triggers) but I don't know what is deal with bltouch because all I accomplished so far is that probe is all the time low or all the time high (it just not triggers)..
  • just a suggestion but have you tried lines 244 &245

    #define ENDSTOP_PULLUP_Z_MIN true
    #define ENDSTOP_Z_MIN_INVERTING false

  • edited February 2017
    i tried this lines like that and the other way around, but as of now I'm been changing anything about endstops and honestly I do not know what to do next. Tommorow I will try again with new configuration on web site, is possibly better to use old 0.92.9 over a 1.0.0dev (beacuse I was only using this one)? And it is possible to use another pin for signal and which (not just zmin or zmax)?
  • if you use z min homing your z probe must be identical with z min endstop pin. Of course you can set to use t max pin for z min homing and probe.
  • edited February 2017
    The setting for bltouch I setup that it works now, but have problem with autobed leveling. 

    Gcode start
    G28 ; home all axes
    G1 Z5
    makes error shown in video, beacuse probe gets deploy when its starts to home to x0y0 after complete G28 when nozzle is at z0.

    If I manualy send g28 home it is OK and then when homed I send G1 Z5 and after G32 also OK (complete bedlevel). But when I start print with this start code bltouch get deployed to fast.

    Even tray to put after G28 "m340 p0 s2200" comand that reset bltouch error, but it is just ignore and dont reset it and gets same error.

  • Using the command M400 solve the problem.

    G28 ; home all axes
    G1 Z5
  • Where did you get 5V for bltouch?
  • RADDS board has also 5V pins. I guess he used of those.
  • Does not work from there. All burned :(
  • How much current does that probe then use? 5V has 500mA in total for all devices I think, at least on mega it was the limit safed by a polyfuse.
Sign In or Register to comment.