Uploaded Firmware to latest and lost my display

edited August 2016 in General
I have HE3D Delta 180 (Kossel Clone) with an Adruino Megga, Ramps 1.4 and looks like a 2004 LCD (this is the one I have http://www.bigtree-tech.com/index.php/en/production/detail/101) .   My system was working before I updated the firmware (I had no voltage on D9). I used the config.h in the version of the firmware provided by the manufacturer.  It uploaded successfully and now the printer doesn't respond and the display is blank.  I tried to revert back using the firmware provided on the SD card from the manufacturer. Still no joy.

I can program the adruino, If I use a blank entries in the wizard,  I can get ponterface to see temps and move steppers. 

What the heck did I do ?
Did I nuke the card ?


  • Looks like a RepRapDiscount smart controller (not the graphic one).
  • edited August 2016
    That was the issue I selected "smart controller from reprap discount on a RAMPS or rumba board" and it worked.  Thank You.

    I spent at least 14 hours trying to figure this one out. Not wasted time, I learned a LOT about adruino and this firmware. Just pissed that the manufacturer configs had the wrong video and sent down this rat hole (when all I wanted to do was change the motherboard for a 33 to a 34. :)  )

Sign In or Register to comment.