Homing my Geeetech G2S Pro - Z OK but X and Y lag behind.

Hi Everyone,

Been trawling the forum for some time but can't find my specific issue.

I have been using Marlin without issue, but want to upgrade to Repetier.
I've entered in all the measurements of my G2S, pretty much straight from Marlin as it's been printing fine.

However, when I hit HOME button the printer will Hit all the end stops as you would expect, however the Z slider is a lot higher than the X and Y slider.

I've tried playing with the different settings in the ENDSTOP values, but to no avail.   It does not seem to matter what values I put in here, Z is triggered (Pulled High) but X and Y never get back to the Microswitch, leaving a gap of about 13mm,

M114 reports that X0 Y0 and Z206 

M119 reports Z H and X and Y both L

My Endstop code currently has the defaults set to 10 for all axis.

Can you give me some pointers to what values I must change so that X and Y line up with Z when Homed?    Thank you.


  • Just testing this now, and noticed if I don't Home the printer, but manually move the Z position up, I can only trigger all the microswitches if I move Y to -6.00, this seems to line up the sliders and all microswitches are then triggered.

    Not sure if that info helps diagnose?

    However, as soon as I hit the home button, same thing.  Z triggers, but then X and Y won't move back towards the microswitches.

    Thank you.
  • Never mind.... Solved it.  RTFM :D

    One of my extruders is bust, so I still had the offest for the second extruder, so the Firmware was behaving as it should, however it was not centered for one extruder.

    Once I set for one extruder, it homes just fine now.
Sign In or Register to comment.