RADDS Serial Header

edited July 2016 in General
So I have a RADDS and PanelDue now..

PanelDue says "Connecting"   It is not seeing any serial information from the RADDS.

Question:  Should I be able to attach a TTL level serial to the pins on RADDS (TX1, RX1, GND) and see something on a serial terminal?
I see nothing, many different settings.

Also, I notice configuration.h has a line in "misc settings",  "BAUDRATE 250000",    What exactly is this?   There is another line for Bluetooth Baud, not the same thing.

I change BAUDRATE to 115200  but still nothing appears on my terminal.  Also set BLUETOOTH_SERIAL 1, BLUETOOTH_BAUD 115200

Using Arduino DUE, are the RADDS serial pins still Serial 1?

Life is rough without a display.


  • Bump...........
  • Bluetooth is independent has own baud rate. And I also guess Serial 1 is serial 1 since programming port is serial 0 and native port is no serial at all. I still need to find a display to connect to panel due to test myself, so can't say much about this.
  • edited August 2016
    So let's say I have a RADDS board connected to a Due and I want to enable bluetooth serial.

    My options are -

    Serial 1
    Serial 2
    Serial 3
    Due Programming Port
    Due Native Port

    Is there anything stored in EEPROM that would override the bluetooth serial settings?

    What setting should put data on the RADDS TX/RX pins?  That is the AUX1  top 4 pins, +5, TX, RX, GND

  • No, bluetooth is only dependent on configuration options. But note that TX/RX is 3.3v on due. Is aux the expansion port? YOu should only connect bluetooth to expansion port.
  • I cannot find expansion port pins on RADDS.  Only AUX1  and the top 4 pins of AUX1 is +5, TX, RX, GND
    Those appear to be part of the same row of pins used on the RADDS expansion board that had 2 additional steppers and bluetooth port.

  • Yes, the 4 pins at the side is what I mean. Just wanted to say that also there is a 5V, RX/TX are 3.3V.
  • I am using a 3.3v ttl logic level USB serial connection, of course.  Don't think it is 5v.
    Regardless, I cannot get anything out on these pins.

  • Should get my display soon, then I will see if it works for me. SO far I had a bluetooth adapter connected to them and it worked. Maybe it is just a communication problem. PanelDue uses some special commands to get json responses about current state.
  • I had to solder on headers for this after everything was installed.  I will recheck my work...

  • edited August 2016
    I rechecked my work, the solder is fine.

  • I give up on this.
    Ordered a duet.

    Beyond frustrated.

  • bluetooth module RX has to be connected to Due TX  and bluetooth module TX has to be connected to Due RX otherwise it will never work.Did you try that?
  • I'm having the same problem. I'm positive I have the correct pins connected,  Din (top pin on PanelDue) is connected to the AUX1 Tx pin on the RADDS. Dout connected to Rx pin.
    JSON is enabled, using the Dev version of Repetier Firmware. Serial 1 selected for Bluetooth, which is apparently? the AUX1 serial pins mentioned above. Bluetooth baud rate set to 115200 - same on the PanelDue. I'm going to try to buzz out the pins from the RADDS header back thru the Arduino header and back to the processor pins to make sure everything there is correct.

    Duet really not an option for me. I need to run external stepper drives. Duet has no breakout for them. RADDS also seems to have a higher capacity MOSFET for running my 350 watt 24v heatbed, 
  • I had it working this week. Needed to fix some code so only dev version can handle it at all. It pointed out that there was no paneldue support at all - it was for the dues server which seems to use different formats.

    Also make sure you select json support for repetier as it is what paneldue uses to get the data. With these 2 changes you can connect. Just do not connect a host on the other connector - that doe snot work as both send line numbers confusing the firmware. Have not verified sd card. Looks like paneldue expect them to be in a special folder which I didn't know.
  • Like I said, I gave up on this.


    My Duet has arrived.   Connected everything, power up, and it just works.  Even color mixing!!!!!!!!

    However, I am now on Reprap firmware.   This will be the third firmware I've had to learn, and getting burned out on this.  Calibration is a nightmare so I may be back to Reprap firmware assuming it works on Duet. w/Ethernet support + HTTP, but I am probably expecting too much.  

    Maybe I'll put the RADDS board in my Prusa someday.

  • Eddie,

    Did you ever try the RepRap firmware on the RADDS? Since the Reprap firmware was intended to support the PanelDue on the Duet, you'd think it would work with RADDS also. Afterall, a serial port is just a serial port... Same processor pins, etc.
  • I had it working this week. Needed to fix some code so only dev version can handle it at all. It pointed out that there was no paneldue support at all - it was for the dues server which seems to use different formats.
    Could you clarify? How do I identify the proper dev version? I am using 1.0.0dev which is offered by the online configuration tool. It doesn't work. Do I need a different version?
  • No latest dev version (after I wrote this) would do. Make sure
    Enable JSON formated info output for ESP8266 Duet web interface, PanelDue (JSON_OUTPUT) in config tool is enabled.

    Also remember Din->Tx and Dout->Rx and not in to rx. Then make sure PanelDue baudrate is same as for bluetooth and bluetooth and bluetooth post must be serial 1. That were the settings that worked for me if no host is connected on other side.
  • To followup on this, it will connect. Unfortunately, I found that only a limited number of functions will work. I can home axes and jog them around. I can also turn on the heatbed, but I have no hotend control (wrong g-code is being sent? - no way to verify)
    It does seems to read temps OK.
    Unfortunately, no SD card data is being displayed, so there is no way to print or read macro files. I'm not sure if the format of the data is a problem for PanelDue, or if SD card file data is not being sent out to Serial1. Pretty much useless unless I'm missing something. Repetier host of course reads the SD card data across the USB port just fine.
    I guess I'm going to have to break down and try RepRap firmware. Hate to do that since I'm already familiar with Repetier.
Sign In or Register to comment.