Problems during homing of Z-axis with dual stepper

edited July 2016 in Repetier-Firmware
Hi, so i have a home built 3d printer with dual z axis steppers with external drivers. and udoo quad and radds 1.5 shield. 
My z-axis motors are connected to 2 stepper ports on the radds. Z axis and E2 using the mirror z function.

Im having some problems with my z axis during homing. Both motors run during the initial movement towards the endstop. But the second phase only one move. 

I tried printing the flute thats on thingiverse, and it looked pretty good for the first 15 layers or so. But the nozzle started dragging in the plastic and pushed the printed part off the heated bed. Im guessing this is related. Is this a bug or is there function i havent seen?


  • Its actually the controller connected to the native z axis on radds thats acting up... I tried swapping them around, and the problem followed the controller..
  • sorry, i meant the z axis output on the radds. Not the external driver :)

  • So if swapping swaps axis it is the settings of the stepper driver. Not enough current I guess. Use the poti to adjust and a multimeter to measure how many amps it will output. Handbook shows voltage->amp conversion. Make sure not to overpower or drivers get quickly very hot.
Sign In or Register to comment.