RepRapDiscount Full Graphic controller - SD card issues

I'm attempting to install a RepRapDiscount Full Graphic smart controller on my Arduino Mega 2560/Ramps 1.4 setup. I'm using the advanced configuration for 0.92.9 firmware. I've gotten things to the point of where the menus show up, I can control motors, and such.

HOWEVER... I can't get the SD card to function.

First off, I need to understand something about the SD card menu - in the event an SD card is not inserted, will there be anything other than the "Back" menu item?

Here's what I'm seeing - when I insert an SD card (I've tried 3 different ones so far - 2 GB with FAT filesystem, 4 GB with FAT32, and a brand-new class 10 8 GB with FAT32) nothing happens. No message, no error. Going to the SD card menu yields only the "Back" menu item.

I've enabled the SD through configuration.h. I've tried a few things with the SD card detect settings. Honestly, I'm walking blind, though, and I don't know how I can tell if it is my fault or defective hardware.

I'm linking to my configuration.h and pins.h files just in case someone can check it out. I would very much appreciate any help.


  • The menu is empty if you have autodetect sd enabled (default for that display). In log you should see a mount attempt when you insert the card or at least a error message and a unmount message when removing.

    I think I have heard that some clone has inverted that detect pin. You could try setting it to -1 in ui.h display section for your display. Then you would get mount/unmount commands. Or invert the signal there.
  • Sorry - Which should I set to -1? SDCARDDETECTINVERTED or SDCARDDETECT? Also, is the pin supposed to be 49 on a RAMPS 1.4/RepRapDiscount full graphic display?
  • I may have answered my own question by trolling the forums. I gather -1 for SDCARDDETECT will give the option for a manual SD card mount. I will try that.
  • Yep. That did the trick. I'm able to mount the card and view the contents. I'll try printing but I think I won't have problems now!

    Thanks for the help!
  • SO that pin is not working for you or should have SDCARDDETECTINVERTED changed to work automatically.
  • I didn't even bother trying SDCARDDETECTINVERTED once I knew what the -1 did for SDCARDDETECT. I like the manual mount feature. I did several prints over the weekend off SD successfully. :-)
  • hello.. @PlacidCat
    well i have been facing the same issue as u have had before and in my case i have tried as the one you have said here and still there wasn't any good solution 
    #ifndef SDSUPPORT  // Some boards have sd support on board. These define the values already in pins.h
    #define SDSUPPORT 1
    #undef SDCARDDETECT 
    #define SDCARDDETECT -1
    Above one is the code i am trying.
    Please help
Sign In or Register to comment.