Extruder motor not enabeling

I am almost done building my own delta 3d printer, evereything works exept the extruder motor.
Repetier host does not show errors. I have set min extruder temp to 0 in configuration.h, I all-ways heat it up to 200 under testing. Dry run is off and the step/mm speed is low and should work.
I have testet evereything in the hardware, including the motor, stepstick and the eletrical connection on the pcb boards are also all-right and not short circuitet to anything.
Evereything is correct in pins.h, and I have tryed moving to second extruder slot without getting any further.

Now I have attached my oscilloscope and the step and dir signals is allright and ticking, but enable is allways pulled high and newer goes low to enable the driver.

My question is short, what can prevent the driver from enabeling? what do I have to check.
I have spend over a week on this and I am out of ideas of where to look. The code is very large and I am mostly a hardware person.

I use newest stable arduino ide, arduino mega + Ramps 1.4, repetier firmware 0.91

Also the enable cold extrusion command does not help

I have searched on everey forum but have not found anything that works for me

I hope somebody has an idea

Else, what will happen if I bypass the firmware regarding the enable pin, and manually enable the driver permantly. Will that screw evereyting up, and make bad prints? 


  • Had the same problem last week and all I needed was inverting enable signal

    // For Inverting Stepper Enable Pins (Active Low) use 0, Non Inverting (Active High) use 1
    #define EXT0_ENABLE_ON 0

    These 2 settings influence enable signal.

    If you bypass it by enabling it always it has no drawback on printing quality. During print it is always enabled. Only drawback is motors will also draw current when not printing. Using RAMPS myself I know at least, that the pins are correct. Only EXT0_ENABLE_ON depends on stepper driver.
  • Thank you
    I was not totally sure what that line did
    #define EXT0_ENABLE_ON 0
    But something is wrong with my setup.
    As I understand #define EXT0_ENABLE_ON 0, then the extruder motor should be enabled during power on, and disabled when printing. My enable signal does not change, the firmware sees an error or something.

    Yesturday I made it "work" my controlling the enable pin manually.
    I have just redefined the EXT0_ENABLE_PIN = EXT1_ENABLE_PIN so that my control dosent conflict, and then made a DigitalWrite(pinname,logic value) after repetier startup in the firmware.

    Now I will start calibrating and playing with the printer. Maybe I will figure out what was the cause of this later sometime.

  • EXT0_ENABLE_ON defines if the enable signal shound be high or low to enable the extruder. Some stepper drivers have this inverted, which is why you can select it.
Sign In or Register to comment.