dac error

I'm having "dac" error when my hotend is heating up. It happens once in a while but it's annoying.  Sometimes the temperature surges up to 230 as it approaches the set value of 210

I usually reset the printer and everything's back to normal.  It somehow works.  But I'ld hate it to happen during printing.

I'm using the 0.92.9 firmware on a Kossel Mini.

Comments

  • What do you mean with dac error? The description sounds like overshoot which is at startup quite normal. Especially if your heater is very strong it can overshoot easily and you might just want to reduce max. pwm value to reduce the effect or increase control range to start earlier with controlling. Outside control range you heat full power for faster heatup, then you heat according PID/dead time.
  • I thinks his mean PWM.
  • edited June 2016
    I'm sorry, I meant "dec"  error.   The hotend temperature on my LCD display says "dec" then the heater shuts down.  
    The final display would be  "dec/ 0".  I have to reboot the arduino then start over.
  • edited June 2016
    There would be a beep when it happens.
  • Dec is short for decoupled, meaning the measured temperature did not match to heater output. This is a protection in case your thermistor gets loose. Then it would not measure real temperature and heat for ever, which normally is too much and melts parts, causes fire, ...

    Assuming this did not happen, your settings are too narrow so they trigger none the less. Check in host log what exactly the reason was and increase decoupling time accordingly to prevent false signals.
  • Thanks for the help.   I will check in the host next time it happens.

     I think my thermistor is getting faulty.  I've ordered new ones.  
  • Ok, if they start jumping with temperatures this could also trigger the decoupled error.
  • Thank you.  I replaced the thermistor and now everything is fine.
  • Hello ronald 

    latly i have the same problem that some users have here 
    sins im using a fan  ,  when the fans turns on the extruder temp going down alittle  which im fine with that .
    but the system decoupled the extruder .
    i was looking at the graph and im sure this is cousing the shot down in mid print  and plus im getting the decoupled  massage 

    in order to make sure i was replacing shield plus arduino ,heater ,thermisitor , at last i was setting the dec in firmware to 0 
    and im still getting the dec massage after disabling it in firmware

    the question is how do i solve this issue , i think that maybe PID will help ? how to disable completely dec  in firmware

    my setting 

    last firmware
    last repetier host 
    ramp 1.4
    im trying dead time control 

    thank you 




  • Ok i got somthing

    disabling DAC didnt help , im still getting the massage and the result of that . (extruder decoupled )
    now... when im not using the fan , the printer didnt stop to print all the way .
    which is good for now  =)
    but when the fan kicking  in when im using it in prints ,  something makes the system DEC after a few second or so .
    my question is ,   lets say ill change the heater value lower then default setting  , is that could help ??
    could i change speed values only for the fan and not the extruder heater 

    thanks

    elidor

  • One part of decouple test is how much temperature may deviate from set temperature if that is reached. I think that is what gets hit when fan kicks in. So your solution should be to increase that value to something that does not happen when fan kicks in. So if fan moves temp 25°C down set it to 30°C and it does not trigger. Only problem lieft is that extrusion might get down a bit due to colder filament until temp. catches up for the extra cooling (which I hope or you have a problem and need to better adjust fan).
  • edited December 7
       elidor said:
    Ok i got somthing

    disabling DAC didnt help , im still getting the massage and the result of that . (extruder decoupled )
    now... when im not using the fan , the printer didnt stop to print all the way .
    which is good for now  =)
    but when the fan kicking  in when im using it in prints ,  something makes the system DEC after a few second or so .
    my question is ,   lets say ill change the heater value lower then default setting  , is that could help ??
    could i change speed values only for the fan and not the extruder heater 

    thanks

    elidor

         I had an issue a long time ago on a different printer(DIY) where my print cooling fan was dropping the extruder temp when it turned on because I just had a mount that pointed it at an angle towards the bed, and partly on the heating block. I made a mini shield to block the area of the heating block and then found and printed a duct that solved the problem.
        You could try to re-aim your print cooling fan so it only blows on the print area, Or print/make a small shield that would block the fan from blowing on the heater block area. I don't know your model but there are fan duct files  available ( free ), that you could print to aim the airflow. Even if the first one does not come out great because you have the fan off, as long as it is usable you can then print a better one with the fan mounted and airflow going where you want it.
       I would not disable any of the features in firmware about safety.
       To run PID there are many references on-line to do it. It is relatively painless.
       Slicers usually have settings for cooling in their configuration.

  • edited December 7
    thank you 

    the deviation is not more then 8 deg so 20 will work fine i guess .
    so why when i was setting DEC to 0 which is disable , still trigger  the dec feature ?
    so i could adjust the fan ? by this Heater PWM speed >> 15HZ >> 30HZ >>61HZ>>122HZ ??



    maybe that could help .. i cant turn on the fan on low speed . it will work only on 98-100 (on fan slider
    - host)

    thank


                                                  
  • Hi roko 

    yes i know this issue , i can work with 5 deg daviation on my prints  , the thing is that i didnt print for along time and 
    i just was trying to disable DAC by setting it to 0 in order to debug , but it didnt solve it so i was confused about it .
    so i was trying to look for shorts on my electronics ,interference and such 
     i have set the Temperature control range 20 to 40 and it works

    i was seeing lots of post that going around this issue ,when you set to 0 its not disabling the feture .


    this is for enable /disable on extruder.cpp tab

    // Check for obvious sensor errors
            if(act->currentTemperatureC < MIN_DEFECT_TEMPERATURE || act->currentTemperatureC > MAX_DEFECT_TEMPERATURE)   // no temp sensor or short in sensor, disable heater
            {
                errorDetected = 1;
                if(extruderTempErrors < 10)    // Ignore short temporary failures
                    extruderTempErrors++;
                else
                {

    so i wasn't sure what causing  the issue ,  im working with repetier firmware from  the begging and i had to update my self about some changes  =).

    after all thanks to ronald we are having good time with the printer =)

    thank you roko for the reminder  and thank you master repetier


  • Hi again 

    is there a way to disable only bed decouple ?
  • Sure, each heater has it's own timing switch

    #define HEATED_BED_DECOUPLE_TEST_PERIOD 0

    should do it at east in dev version. Not sure what works in 0.92.

  • Thank you  :)
Sign In or Register to comment.