Calibration just wont work ( delta printer )

Hi there!
So, I've been trying to calibrate my prototype machine for days now. I mean, can it really be that complicated? 
So today I went a new approach. I've read that one should G32 S2, then go to the lowest Z value possible and add/subtract the Z value from the Z-Probe height. Well I guess that worked like a charm. 

I started with Z max length: 574.200 and Z-probe height: 32.500. Nozzle was touching the bed at Z=20, so I changed Z max length back to 574.200 and Z-prove height to 12.500.

I did that until the nozzle was at perfect distance from the bed while Z=0.

Here is the output from the last G32 S2 command:

I then ran G33, here is the result:

So, it does not work. Well, technically it does. Attempting to print results in a floating nozzle which even goes higher in the air at certain points, it's like reversed. I guess something is wrong with my geometry, angles and stuff. But I just dont get the hang of that. 

Some more things which aren't really working well:

- If I try to use the height map tool, it always crashes into the side walls of my printer
- This issue came after I've done the stuff I mentioned before, just noticed that if i home and then move Z down like -10 with repetier host, X and Y move down and Z is staying in place. M119 reports every endstop untriggered after homing. ( L )
- Sometimes I am skipping steps. If I start a print as example, while the effector moves down I can hear somewhere it's missing steps and as a result it starts printing in mid-air. Also sometimes after G32 S2, at the exact moment where the last point has been probed and the effector moves back to center, at the start of that move I can hear a humm. It's the humm you'd hear if you have your acceleration way too high I guess, but it's very short and the move continues after that.

So I am really sorry to bother you with my problems, I tried to figure it out for so long now. I just can't anymore.

Here are some of my settings / my configuration: ( still can't figure out how to set frequencies, quad stepping, delays... )
- Nema 17 stepper motors (59Ncm, 2A
- A4988 pololu drivers ( China, VREF: 0.35v for x, y, z and 0.62v for extruder ) 
- Arduino Mega 2560 ( China )
- Repetier 0.92.9
- Mechanical Endstops, NO & GND ( ZMax, YMax, XMax )
- ZProbe Mechanical Endstop, NO&GND ( connected to ZMin )

Endstop configuration:

XYZ Movement configuration:

Movement & Delta settings:

Z-Probe settings:

Drive system & steps settings:

And in case i missed something, here is my entire configuration:

Thank you so much!


  • Your measured values are really bad - I guess you have not 11mm difference in bed tilt?

    #define ENDSTOP_Z_BACK_ON_HOME 1
    should be more 20 or even more for deltas as any small xy move could trigger endstops at top otherwise. Reduce z length accordingly.

    Then first configure end stops with G131/G132/M99 as described in our z leveling tutorial. Also make sure that after homing z down moves all motors. If not do not expect anything else to make sense. Also start commands like G33 only near bed to prevent the mentioned problem at top.

    Put your 3 measure points near columns if you do 3 point measurement. See eeprom for values. After G32 S2 the distance at these 3 points should be the same to bed. This is only valid for these 3 points as your printer geometry description might be wrong. First fix diagonal rod length/horizontal radius as good as you can so that distance in bed center is at least the same. There are many docs how to calibrate these variables.

    Only when geometry and z probe height are calibrated so that after G32 S2 you have Z=0 nearly the same, then you can start using G33 to fix the remaining small bumps.

  • edited June 2016
    Thank you for the rapid answer!
    I did what you said, not all of it tho. I'm through with G32 S2, as you said the distance for the 3 points to the bed is the same. Now I am going to fix my rod length / horizontal radius.


    I also notice some weird clicking noise in my motors, only after I home. Takes around a minute or more after homing and they randomly start clicking, as if someone would turn them step by step. 

    /E: I just noticed that if I try to like move down to the platform while the grinding noise is there, I am constantly loosing steps on the way, so now I know the origin of the problem I mentioned before, loosing steps sometimes. But I dont know why the grinding noise appears after all. I guess it has something to do with the motor "standby" after some time?
  • Just reporting that the calibration went well! Finally it's done, thank you for pointing me in the right direction!
    However, some problems still exist. Mainly the losing steps one. It's getting worse and I can't seem to fix it. 

    Also, if I move my effector down, say for starting a print, it does not go down in one rush. It stops like 3 times at the top and will then eventually go down in one move. The stops aren't abrupt, they are kinda smooth. I guess that has something to do with the losing steps problem.

    Vref should be right, shouldn't it? 80 steps /mm, 50mm/s^2 travel & printing accel, 18mm/s jerk
    Can't find the problem here.
  • Your measured values are really bad - I guess you have not 11mm difference in bed tilt?
    First#define ENDSTOP_Z_BACK_ON_HOME 1
    should be more 20 or even more for deltas as any small xy move could trigger endstops at top otherwise. Reduce z length accordingly
    Do I just change this line?  how about the X,Y?#define ENDSTOP_X_BACK_ON_HOME 1#define ENDSTOP_Y_BACK_ON_HOME 1#define ENDSTOP_Z_BACK_ON_HOME 20
  • You get some pauses at the beginning, because the path planner is empty, so it goes to jerk/2 speed. Nothing that looses steps. Once you print buffer fills and everything is fine.

    Can't say about vref, but if drivers get too hot they go into thermal protection and that causes lost steps. So maybe reduce Vref or cool them better. 50mm/s^2 is very slow acceleration. I normally use around 1000 others go even higher.
Sign In or Register to comment.