[Newbie][Prusa i3 steel frame] Z axis moves really slow and doesnt go all the way up

Hello everyone, my name is Mariano and i am configuring my P3Steel using RAMPS 1.4 (drivers Allegro A4922) and NEMA 17 1.8° 1.7A.

I make everything work ok (heated bed, extruder, X and Y axis) but Z axis is moving really slow, and doesnt go all the way up. its only getting 1/10 of its height approximately.

I tried changing several configuration in firmware but no results.

Does anyone had the same problem? I appreciate your help.

Thank you very much


  • Tried Marlin firmware and it works ok.

    Im changing to Marlin.

  • i have the same problem but i have ramps 1.57, any help or configuration file to use, i don't want to go to marlin.
  • First check if steps per mm in z is correct. Change them in eeprom (configuration.g does not work once uploaded unless you change eeprom mode or copy using M502 and M500). Also make sure z length is set correctly s that depermines the way to go up. On prusa you can not go too fast or you loose steps so use moderate acceleration for z (50-100) and check possible speeds (2-10).
  • would be nice if anyone have the configuration file. one question more, what voltage is advice to use on ramps 1.57?
  • Voltage depends on stepper driver. See docs for driver and what your stepper motors can handle. If it stops working from overheating it is also too much, so check for good cooling. Especially if you have 2 motors on one driver it gets hot.
  • i have a prusa i3 from http://www.aliexpress.com/item/Black-Factory-High-Quality-Precision-Reprap-Prusa-i3-DIY-3d-Printer-kit-with-2-Rolls-Filament/32357171936.html?spm=2114.13010608.0.97.XNc17K

    and put a ramps 1.57 to use and i can't find what values are the best to use on my configuration. would be great if anyone already had the settings and share with us.

Sign In or Register to comment.