Problems uploading 92.9 to MKSBase 1.3

So was in the progress of making a version of this for me and some other people with the same type of printer (TEVO Tarantula) that uses an MKSBase board. 

Version 92.8 uploaded fine, but version 92.9 would stall and give the dreaded avrdude timeout error. After much troubleshooting I have determined that the issue is the commented out lines @ 510 and 511 in Printer.cpp when I un-comment them the firmware upload just fine.

Not sure what is going on here, maybe I am the only one having this problem, but I can tell you definitively that I do not have to have both uncommented but uncommenting either one or both will allow the sketch to upload to the board, having both commented out will cause it to stall and timeout. 


  • These 2 lines do nothing and uploading is independent of the code anyway.

    There is only one bug in upload protocol that !!! in binary data will fail to upload. So maybe that change just removed involuntary existence of that combination.
  • I totally agree. Although I tried putting other meaningless statements in there like a "float throwAway = 0.00" and that didn't help. Anyways just wanted you to know in case it comes up, my problem is solved for now but you may want to put those lines back in lol :)

Sign In or Register to comment.