Kossel Type Delta Bed Leveling Problem

edited March 2016 in Repetier-Firmware
Hi Repetier, we have a promlem repetier firmware 0.92. We have delta 3d printer with kossel design but it doesn't auto level. We do step by step  like bellow: 

m99 x, y and z to stop motors and by g132 s1 save endstop offset

After these commands center, x tower, y tower and z tower near nozzle height arent equal 


  • 1. We have just updated the firmware with a new formula for rotation computation. Depending on point positions the old one could have a problem in the formula.

    2. Wrong geometry definition can cause also strange results. Especially center to tower heights are wrong often because diagonal rod length/horizontal radius are wrong.
  • Hello

    the same problem with my Delta

    I commend old version it work ??

  • So with 0.92.9, how to auto leveling in Delta?
  • Procedure never changed, you only can now use grid measuring in addition if you compiled the firmware with that. Default is still 3 point bed leveling.
  • edited July 2016
    I used z-probe on pin 63 (proximity sensor, Kossel MiniMax). Send command M119 and receive answer:
    z-probe working!
    But when send command G30 or G32 S2 z-probe don't work normal, stepper motors move on and don't stop.
    Can I have something setup wrong in the firmware?
    Including screenshots my setup firmware endstops and z-probe settings.

  • Looks ok so far. Question with proximity sensors is when they trigger. Have you tested going to test points manually if sensor then triggers? If you are too far away from bed it might just not trigger so it wants to go down more.
  • One more thing - make sure zLength is max. real length, rather a bit shorter. First move goes down zlength-probe bed distance. If that is below bed you crash into it.
  • Thank you! The problem really has a zLength and zlength-probe bed distance parameters. It works fine now.
Sign In or Register to comment.