Autoleveling with Repetier constantly failing

edited March 2016 in General
Hello everyone

I am about to lose my mind. I have a RADDS / DUE board setup with a Z-probe on a servo lever. As required by Repetier 0.92.8 firmware I have a Z-max endstop to measure the z-length. All sensors return correct state when triggered, servo extend/retract is ok, all motors work fine. Here is the one unsurmountable problem now: I cannot figure out how to run G32 S2 command properly. It ends up telling me this in Repetier Host:

09:26:39.629 : Error:z-probe triggered before starting probing.
09:26:39.631 : Error:Probing had returned errors - autoleveling canceled.

I also posted a video here. First, I issued a G28 to home all axis, then G32 S2. Probe touched the bed, then moved to the right and then the alarm went off, the extruder started to move back up. End of story, end of ideas.

I have tried tons of different settings Z_PROBE_BED_DISTANCE, Z_PROBE_HEIGHT, changed Z_MAX_LENGTH - to no avail. The config I used when I shot the vid is here:

Oh, and what I always do after flashing firmware is this series of command:
M502 ;
M500 ;
M501 ;


  • OK, I figured it out myself. It turned out I had the Z_PROBE_ON_HIGH the wrong way round, which is what the error above suggested but I did not check. The reason I did not check is that I have the same type of sensor wired as endstops and the value for the ENDSTOP_[XYZ]_MAX_INVERTING set to true. 

    So Z_PROBE_ON_HIGH set to false was the missing bit.

    Quite confusing that Z_PROBE_ON_HIGH  and ENDSTOP_[XYZ]_MAX_INVERTING have opposing values. Took lots of trial and error finding it out.
Sign In or Register to comment.