Z Probing coming up with an error

edited November 2014 in Motor Control
Hi All

I am having a serious error when trying to z probe and have no idea what it means, I activate my probing by typing in G32 and then it moves to position, i then click the z probe to start, once this has happened it will lower its self towards the build plate and when it hits it seems to come up with the following error. your help would be much appreciated. Thank you in advance.

23:02:22.095 : Error:A hit floor
23:02:22.095 : Warning:Invalid delta coordinate - move ignored x:9552 y:2000 z:-5695
23:02:22.099 : Warning:in queueDeltaMove to calculateDeltaSubSegments returns error.
23:02:22.099 : Warning:moveTo / queueDeltaMove returns error

I have an Arduino mega with Ramps 1.4 using repetier firmware and host



  • There is a test if one of the carriages may hit the floor. This happens when you are near the edge with some printers. In eepromit corresponds with xyz min/home value and in config it is this setting I think

    // Margin (mm) to avoid above tower minimum (xMin xMinsteps)
    // If your printer can put its carriage low enough the rod is horizontal without hitting the floor
    // set this to zero. Otherwise, measure how high the carriage is from horizontal rod
    // Also, movement speeds are 10x to 20x cartesian speeds at tower bottom.
    // You may need to leave a few mm for safety.
    // Hitting floor at high speed can damage your printer (motors, drives, etc)

    Maybe it is too high for your printer.
  • I probably should have mentioned I have a Delta printer and using the z min as my auto level function, would this make a difference? I will try setting my margin to 15mm
  • It'S fine to use zMin pin for probe. Just do not say you have a zMin hardware endstop. You have z probe connected to zMin whcih is a different thing.
  • I had almost the identical problem, my issue was that the EEPROM contained bad values for leveling which made the printer go berserker.
    Sending a M502 to the printer, thus restoring all factory settings from the firmware and then redo the leveling resolved all issues.
    Thought I post this if you still have problems, or if anyone else runs into this problem.

    My full sequence in autolevel.g on my SD:

    M502; Reset, read firmware into EEPROM
    G132 S1; 
    G32 S1;
    G32 S2;
  • If M502 helped just do
    once to update eeprom. From there on it should be unneeded.
Sign In or Register to comment.