Rep 1.6.1 not printing from SD card.

Ok, using Windows 7 Professional, have upgraded my Two-Up printer to the 3up by DDegonge888 on Thingiverse.  With Rep-Host 1.5.6, I had no issues.  I have the red Printrboard Rev. D. Was printing fine from the SD card as always, then upgraded to Repetier Host 1.6.1.  I was able to see what was on the SD card when it was in the Printrboard.  I was unable to print anything that was on that list.  Was unable to load anything to the card through Repetier Host, but after I tried, and then took the card out and used a dongle, I would see some sort of file that tried to be loaded onto the SD.  Basically the only function was the ability to read what was on the card, no write or run options worked.  Uninstalled 1.6.1 and then reloaded 1.5.6 and was able to run again.

Also not sure if it's related, but when you hit print from SD, you can't disconnect while the Hot end is heating up, locks the program up and the hot end keeps heating.


  • Prints have a waiting heat up that can not be interrupted, that is normal.

    Which firmware are you using. I lately changed something because marlin sd got incompatible and new version now works. But maybe that breaks the other half of marlin users.
  • I'm sure it's not the heat up time or anything, first move when a print starts for me is g1 x0 y0 z15 while the hot-end heats up.  It never even moves.  There seems to be a communication error with the SD card of some sort when using 1.6.1.  I can print tethered with the 1.6.1, but the SD card will only see what is already on the card and do nothing else.  When I change back to 1.5.6, everything worked exactly as it should, like I never changed anything.  In any case, I'm printing again, will try the 1.6.1 again another time when I have time to try more stuff.  Thanks for your time.

  • I am using version 1.6.2 of Repetier Host with a Printrbot Simple Metal, Rev F5 control board and am having a similar problem when trying to print a file that is stored on the printer's SD card. The previous version of Repetier Host that I was using, version 1.0.4, works perfectly. Version 1.6.2 will display the list of files stored on the SD card. However, aas an example,  if I select a file from the list with the filename of "SMBOX.GCO" and click the "Print" button I will get an error message in the log that reads..."open failed, File: smbox.gc.   Note that the file name has dropped the "O" from the end of the filename and replaced it with a "period"

    Here is the log listing-

    23:02:41.553 : Begin file list
    23:02:41.556 : 12345678.GC
    23:02:41.556 : SMBOX.GCO
    23:02:41.556 : SMBOX.G
    23:02:41.556 : 3BOX.G
    23:02:41.556 : BED_WEDG.G
    23:02:41.559 : End file list
    23:02:41.563 : echo:Active Extruder: 0
    23:02:55.637 : echo:Now fresh file: smbox.gc
    23:02:55.637 : open failed, File: smbox.gc.

    Any suggestion on how to correct this issue?

    Thanks for your help

  • Can you also show the command being send?
    echo:Now fresh file: smbox.gc is wrong as the file is named SMBOX.GCO. So question is does the host not send the "o" or is the firmware removing it for some reason.
Sign In or Register to comment.