Extruder motor issue on Delta

Download latest firmware from site wizard with this config inside

If I press control buttons in repetier-host, my extruder motor just whistles and dont turn . Cold extrusion allowed with M302. G10 command disabled in firmware.
Print from Simplify3D works, except retraction has only z-lift of head(as I setup) and no filament reverse movement(I set 4mm).

If I only change #define DRIVE_SYSTEM 3 to 0 in config, extruder turn from repetier-host buttons commands as expected.
Also works in Marlin.

Why extruder work during print and whistle from repetier-host buttons?

Here coomands from Host log
00:58:34.174 : N347 G1 E1 F120*41
00:58:38.355 : N351 G1 E-1 F1800*57

Try master branch from github with default config - get the same results. Set DRIVE_SYSTEM 3 broke my extruder motor motion.


  • If printing works and retractions or manual moves not, it is normally a wrong setting for start speed/acceleration causing the motor to stall for fast moves while the slow printing moves are no problem for the motor. 

    So check in eeprom what values are really set - your config settings seems sensible for most extruders but maybe eeprom has other values. Also check motor current if that is for some reason lower as it should be. If you set a low extrusion speed in host (printer settings) it should also work. 
  • I erased EEPROM dozens of times, try increase and decrease speed and acceleration in extruder. Try to invert motor direction and enable signal.
    Exported values from EEPROM
    <epr pos="200" type="3" value="150.000">Extr.1 steps per mm</epr> 
    <epr pos="204" type="3" value="50.000">Extr.1 max. feedrate</epr> 
    <epr pos="208" type="3" value="20.000">Extr.1 start feedrate</epr> 
    <epr pos="212" type="3" value="1000.000">Extr.1 acceleration</epr>

    Motor current above middle. It works nice during 60mm/s print. 

    Why change DRIVE_SYSTEM helps? EEPROM values are the same. 

  • If I understand you right printing always work but changing extruder direction only works for cartesian system?

    That would be strange since extruder and drive system are completely independent. If it works in one system it should work in the other.

    From which date is the firmware. 0.92.8 had already several updates so that may matter.
  • Printing work with DRIVE_SYSTEM 3,  except retraction. But this may be slicer settings issue, I will try print from Cura.

    From repetier host button commands extruder motor move in any direction only if I set DRIVE_SYSTEM 0.
    It works well with a specified in EEPROM speed. 
    With DRIVE_SYSTEM 3 it dont turn, just make little noise, then I send commands.

    I dont tried to print with DRIVE_SYSTEM 0, because I have delta printer )

  • edited March 2016
    Sounds very similar to the issue I am experiencing: http://forum.repetier.com/discussion/1720/retraction-reverse-extrusion-not-working
  • I'm also having the same issue, after upgrading two days ago to the latest firmware, printing(forward extrusion) works but retractions aren't, also manual extrusion or retractions not working, everything was working fine before the update, I don't remember what firmware version I had before, but I downloaded and installed it in November 2015.

    Oddly, I don't think I see retraction commands in the generated gcode, only one "G1 E-6.00000 F1200.00000" at the beginning, but nothing else, I'm using Slic3r, and retractions are enabled in the configurations, and as I said, I haven't changed anything from the working setup except the firmware update(which by the way, solved another problem I had with a thermo coupled fan, so thanks!).

  • edited March 2016
    I can confirm that the Extruder works only properly if DRIVE_SYSTEM is not set to 3 / DELTA. When set to 3 the Extruder motor will just power on and not extract / retract when adjusting the Extruder position using the panel connected to the Ramps board. 

    So to sum it up:
    • DRIVE_SYSTEM == 3 : Extrusion only when printing, no retraction, will extrude *once* when triggered via Repetier-Host
    • DRIVE_SYSTEM == 0 : Extrusion works as expected in both directions via connected panel. 
    Verified against latest master (e5a0a826c6c32d2536fa9fca5c8b99b5374a9072)
  • I'll add i'm also using a delta printer.
  • Hi,

    Same symptoms here with a basic RAMPS delta printer under 0.92.8 : Extruder does not move, except while printing. 

    Since my hardware is over-tested with previous RFW versions installed on the same RAMPS combo, I started going crazy. I am relieved to see that this is probably a bug !
  • I will try bisecting the FW this weekend. If anyone else wants to give it a shot, 5474f2ded5db26aa9000b63b1a9e800d133d2fd4 commit id could be confirmed (on irc) to be good.
  • I installed the previous firmware I had and the extruder is back to working properly now, don't know what version it is(where do I see that?) but it was downloaded from the configuration tool in November 26th, 2015.
  • Found it, Version 0.92.6
  • edited March 2016
    ok guys i set DRIVE_SYSTEM == 0 on configuration.H and upload to mega via ide, but not work here, extruder still not moving.

    any tips ?

    from eyal : G1 E-6.00000 F1200.00000 make then dop a first turn, but after it, they don´t turn anymore.
  • This made me curious since I have lately changed some nonlinear code. So I uploaded latest version from master (4.3.2016) to my delta to check retraction. Well it worked as it should, so in general it works with that release.

    Especially since it works with system 0 and switch system does not add pins just handling makes it a mystery. So maybe just update to latest version.

    Also what IDE did you use? I used Arduino IDE 1.6.7.
  • arduino 1.6.7 here, do you can give me de directions to try the latest version from master (4.3.2016) i use the tool of the main site.

  • So maybe just update to latest version.

    Also what IDE did you use? I used Arduino IDE 1.6.7.
    I also don't understand exactly what you mean by latest version(master 4.3.2016), at least for me, using the latest version from the configuration tool is what caused the problem, I tried downloading and installing it again now and I got the same results, however, using version 0.92.6 fixes these issues.

    I'm using Arduino IDE 1.6.7
  • Arduino 1.6.7, latest version from master (4.3.2016) - the same result, no manual extrusion.
    Arduino 1.6.5, repetier 0.92.6 - manual extrusion works.
    Arduino 1.6.5, repetier 0.92.7 - manual extrusion works.
    Arduino 1.6.5, latest version from master (4.3.2016) - manual extrusion not work.

    All with the same Configuration.h, that I have posted above. EERPOM not erased.

    Eyal, you can download latest version from here https://github.com/repetier/Repetier-Firmware/archive/master.zip, or use git client like SourceTree.
  • Thank you bazis!

    Downloaded and installed latest version from master(4.3.2016), and no luck, still no manual extrusion.
  • Did anyone with retraction issues *not* use the "Config.h-Web-Wizard"?

    I checked the contents of the vanilla config include and the one generated by the web app - a couple of defines are missing in the generated one. 
  • @Repetier

    ➜  Repetier-Firmware git:(d4e396d) git bisect bad
    d4e396d0f4d1b81cc4d388360be461f11ceb9edd is the first bad commit
    commit d4e396d0f4d1b81cc4d388360be461f11ceb9edd
    Author: repetier
    Date: Fri Feb 26 14:55:33 2016 +0100

    Fix jerk, updated nonlinear code,added zonestar 802M

    :040000 040000 ec0a648a3aa3886ddbc4a73ddf1c2f000c3dd7d9 27add6cc5d793c2522a54a600ccfc024029e1f13 M boards
    :040000 040000 48d1913901f8979837750a570ea4629d988a6881 772d0f02039e47b62c898b0045f406a3ecad5fc2 M src
    ➜ Repetier-Firmware git:(d4e396d)
  • Ok, found the problem. It only happens on nonlinear printer with AVR chip. I tested my delta with due.

    Have now updated all sources with the fixed version.
  • \o/ 

    fix confirmed, just did a test running 90a063ab0d8fb34efb2b5de7ca03e4ff56bfa277

    Thank you for looking into this.
  • 0.92.8 reloaded from the configurator, then compiled with a freshly reinstalled 1.6.7 Arduino IDE : everything works fine !

    Thanks, Repetier !
  • Working for me too :) Thank you very much!
  • Mine works too. Thank you, Repetier.
  • I'm Desperate to return to home to try too. . :((
  • 07-03-2016 : i make a entire new config from web wizard, and now everthing is running fine !

    thanks guys, repetier rocks !
  • Hi all, I have had a similar issue with my Rostock Delta, I am using Repetier-Host and Repetier 92.8 firmware.
    My extruder stepper would not move forward in Manual Mode using R-H and it would only retract 1mm . 
    I had homed my machine.I noticed that my Z height number would go from Black to Red when I tried to manually move the "at temperature" extruder.
    BUT it would print under program control. I also tried other programs to print with, same-same.
    I was looking at my EEPROM settings and found that X max length and Y max length were the same but did not match my Z max length. (for some reason). 
    I made them the same and "Viola!" manual control was back!
    I also found another interesting thing, I had set my Z max height in the frimware and then I set it using the Graphic Control Panel. The number became lower but was not changed in EEPROM on the menu. That's why it was going red. I made it correct to match the actual Z-max and it stayed Black.
  • Oops, I apologize.
    Please disregard my preceeding post, I don't think the information in it is accurate. 
    Again. please disregard
Sign In or Register to comment.