Extruder won't move (3 mixing Extruder)

It's my first post here so if I'm doing anything wrong..

So my problem is that none of the extruder won't move, I'm using Repetier FW and host.
All 3 extruder moves with MarlinFirmware. So I know all drivers and stepper motor works fine.

I have heated the extruder to 210c (min extrusion temp is 170c).

I also have tried the M302 (I got the message cold extrusion allowed).

I have used M502 & M500 to reset te EEPROM.

I don't get any errors or messages preventing the extrusion it only give me the Gcode expected.

And it is not in dry mode.

Well I hope someone will be able to help with that.


  • Check eeprom. Since you have a mixing extruder chances are high that mixing ratios are not set correctly. For each virtual extruder at least one of them needs a non zero value.
  • Just found out what was the problem.
    for some reason the configuration tool only changed the steppes per mm for extrude number 1.
  • I've got a pretty similar situation - I've got a delta with 2 mixing extruder on ramps 1.4. Both of my extruders work with Marlin firmware, but with Repetier they just freeze up when I try to manually extrude.
    I've heated the hotend up to the correct temperature, enabled cold extrusion just in case.
    Weirdly, if I reset the printer - both extruders work, but at the same time the Z-tower carriage starts sliding up. As soon as it hits the endstop, the extruders stop working again.
    Have tried M502 and M500 and then setting the extruder parameters again to no avail.
    Some help with that would be greatly appreciated.

  • Sounds like your extruder use the same stepper driver as z axis. That can only make problems. But that is in configuration.h and not in eeprom in that case, so better check there.
  • Checked that - extruder pins are defined as ORIG_E1 and ORIG_E2 pins, and those are also correctly defined in pins.h. Also, the extruders only work until the 1st hit on the endsop - after that both steppers are locked and the xyz movements continue as before.
  • My issue was similar and I solved it by replacing EEPROM values with default ones.
Sign In or Register to comment.