Stepper issues with RADDS + DUE + RAPS128 (Cartesian printer)


Decided to upgrade my controller to a DUE with RADDS + RAPS128 drivers.
I've followed the steps in the site to have Repetier set for this but I can't get the steppers to move correctly.

For the X when moving in one direction it sometimes even moves back in the opposite direction and in long continuous
movements (i.e: homing some small stops can be see at intervals)
Video example : 

For the Y it just pauses and moves and pauses and moves, non-stop... and I end up having to reset the printed. :S

I'd assume this must be some setting that I'm missing.
Anyone care to share their configuration.h so that I use it as base to create mine.



  • Have you checked RAPS128 temperature. They will stop when getting too hot.And it is easy to get them hot. So put a fan on them or reduce motor current to keep temp. in good range.
  • I kept checking their temperarure. And they were was always cold to the touch.
    That was right after turning on the printer.

    But it gets even more weird with the Y axis. That after any movement it keeps moving on it's own.

    In there I only made it home the Y axis.

    I thought it could be the RAPS128 drivers and swapped them to some DRV8825 I have but it does the same.
    So I guess is something with the firmware or the DUE?
  • I have 2 printers with due and both behave correct. SO firmware would handle it correctly under right circumstances:-)

    So lets assume it is a configuration issue, also I do not knwo how to change direction during a move. Also if you have an lcd check what buf is saying. Buf=0 means no steps are set/unset and nothing should move. This is with respect to your keeps moving problem.

    You could switch stepper sockets so xy use E1/E2 for testing, in case these pins get signals from an other source. Also make sure no Thermocouple/fan/... is using any of the driver pins. Thermocouple 1-3 use pins from x socket!
  • Oh I definitely assume I screw up something with the configuration. :)

    Actually I just ruled out any hardware problem.
    I loaded Marlin4Due just to test it and it worked fine, all Axis working smooth as silk and no odd behavior.

    Now that I know that I definitely messed up the settings I'll put Repetier back and try those thigns one by one.
    Maybe starting with one single axis and move it to E1/E2.

    Thanks @Repetier.

  • @Repetier, did a bit of testing and found what is causing the conflict.
    Is actually the LCD choice, if I enabled the the LCD choice "RepRapDiscount Full Graphic Smart Controller" 
    all that weird behaviour starts to happen.
    Haven't tried all LCD combinations but other seems to have no issue.

    Have you have encountered this? Probably some pin conflict.
  • You could say pin conflict as there is no pin mapping for RADDS->RRD GLCD in ui.h. We have only mappings for RADDS Display and the Sparkcube RADDS display. Is there a official connector for that display or how did you map the pins? Especially the sd card should be problematic with a 3.3V system.
  • I don't have the LCD physically connected yet.
    But I was hopping to get it working. Prior to deciding to get a RADDS I searched for it and found some details of people that managed to do it.

    To be honest I could even ignore the SD card support. I use Repetier server for printing so I never use the SD card.
  • Since the RADDS has a lcd connector with 5v the lcd should work with the right pins configuration. You just can not push the connector on it but need to decide which pin goes where and set pins in ui.h accordingly.
  • Ok got it.
    I guess I can look into the definition for the Sparkcube RADDS display pinout and see what is available and then change it accordingly.
  • Yes, the sparkcube lcd is the same lcd type I think also without sd card. So just connect with the same pins and it should work without modification.
  • edited August 2017
    Sorry to bring this up again. I had the same config as Nandox7. I do have a lcd adapter for the radds (not installed yet). but I had it configured in Repetier 0.92.9. The same stepping issue happened. Removing the LCD controller fixed the issue. Is there a fix available?
    Oh and by theway. it is EXACTLY the same: X moves and then backs up, and Y moves intermittedly
  • What controler did you use? Radds display or sparkfube graphics display? These are theonly one i think having the correct pins predefined. Using wrong pins can cause this especially if pins point to motor pins.
Sign In or Register to comment.