Has anyone gotten this to work in Repetier Firmware?

I've seen a couple posts asking questions and a comment on the indiegogo page that someone was having trouble with it


  • I have used one of these sensors in MarlinFirmware and it worked well.

    The only odd thing about the sensor is that to drop the pin down below the nozzle it is a servo movement (setting servo to 10 deg from memory. And 90 to raise it)
    BUT every single probe needs to have the servo called to 10 deg so the pin can drop down again..

    Is this how repetier works @repetier
  • No, repetier has a start and end command to enable/disable a probe but after that it assumes it works.

    But you can easily hack runZProbe to execute an additional gcode command if required:

  • edited January 2016
    That worked! @repetier thank you for your time helping.

    Is there a way to add that sort of a "hack" to a G28 (Zxytz) I had a look at the code to try this but I am uncertain where would be an appropriate location to insert it.

    I am asking this because my printer has an enclosed chamber and it is hart for me to add z max endstop at the moment and I have parts I am needing to continue making for the next few weeks.
  • I guess homeZ would be the right function. There you have 2 moves down where you would need to add it.
  • i am looking to hook up a bltouch on my Printer too,

    could someone please explain me how to manage this with repetier Firmware?

    I am not sure where to "hack" runZProbe....

    @repetier, is it possible that you implement the feature on the next FW update?

  • The function to hack is in BedLeveling.cpp in latest version. Just put the hack in the first line of the code I guess. But I do not have the probe so I can not test and program. But I guess it is just some servo movement gcode you need. If that works I could add a per probe script in addition.
  • I am just looking at getting the BLTouch working on Repetier.  Is this hack still required, and has it been tested and proven to work?  Many thanks!

  • Have someone solved the Problem? Can you Post your ZProbe Settings?. Thx
  • I also would like a good tutorial on adding the BLTouch to Repetier. Repetier has got to be the worst firmware for finding good tutorials on....
  • Here are my settings:

    No hack required the probe releases itself after touching the bed.
  • After trying bltouch to work for 2 weeks I decided to opt it out. Now I purchased an 8mm inductive sensor and will try it.

    I had several problems with voltage, auto bed leveling, nozzle height. It works with Marlin but with Repetier I believe still needs some development.

  • I use bltouch with repetier and have no problems with it.

  • @MartinH could you share your configuration, or your how-to, it'll help few people like me :)
  • edited May 2017
    Attached is my config file that i am using with a BLtouch.
    Make sure you use the dev version of firmware
    Use homing option x y preheat Z
    set it to allways raise Z

    edit/ cant see the attachment so here's a link
  • We had endless problems with BLTouch on 1.0.0dev, replaced with inductive sensor (as ZMIN/ZPROBE) and life became quite a bit more easy (or at least more reliably-behaved).  Still seeing some oddities w.r.t. G29 vs homing ZMIN but able to work around those by relying on ZHoming instead of "G29 S2"-ing.
  • I have done a tutorial on setting up the BLTouch, hope it can help someone. 

  • Hi. Im trying to install a bltouch clone (3dtouch , is exactly the same) so I guessed this instructions shuld have worked for me. But Im havening something wrong and I cant find what it is. I have recompiled the eprom (configuration.h is atached) I uploaded, priter responds to mvements and commands. But following the video instructions I got to the point where I have to calibrate the probe/ noozle offset. I tried to execute the command M340 to move the probe up and down. I execute the commands as seen in the video and I get nothing, in the console I dont even get "unknown command", I just type the commands , enter, and nothing happens. I double checked the cofiguration.h config, my 3d touch is wired like this

    Any ideas what Im doing wrong?
    Thanks in advance

  • O partially solved it. For some reason my ramps board is not delivering 5V in the servo pin... I tried gettin 5V from the aux pins and now the 3d touch works, but still Im not bein able to complete the steps,I was able to measure the x/y offset, introduced that in the firmware, but I can not get the rest of the instructions, when I do a g32 step, I get an errer saying "23:06:16.984 : Error:Activating z-probe would lead to forbidden xy position: 20.700000, -11.60"

  • Tinchus2009, that "forbidden xy position" (especially the -11.60) indicates that your probe is located "behind" (at a greater Y position) than your extruder.

    As such, you need to adjust the Z-probe offset y to be AT LEAST 11.60 (how far from "HOME" [presumably 0,0] the probe is):

    Here, you'll see my setting for 105.990, meaning MY probe is 105.99mm away from my Y-Axis "home".

    If you stop to think about it, it makes sense...  The printer can't move the PROBE any closer to the zero "edge" (of the Y-Axis) than 11.60mm, so you need to update the EEPROM to reflect this offset.

    Same thing for the "Z-probe offset x"...  How far from the extruder is the probe (on the X-Axis).

    Hope that helps...
  • Hi
    I have a problem with bltouch  with rumba board
    i'v connected the bltouch into Zmin and EXP-3 2,4,and 6 pins (PWM2).
    Then I configured repetier like Pigeon shows in his tutorial

    In Servo configuration I don't know what to choose and I'v left Z min endstop

    After compiling ad writing it into the board the BLTouch don't response to any commands to test it.
    The compilation was ok
    Can anyone done bltouch with rumba and repetier?

  • here is a good video on connecting bltouch to a rumba board.

    servo 0 pin in your config needs to point to which digital pin the bltouch is connected,  so pin 5 as in the video.

Sign In or Register to comment.