define steps per mm for all extruders separately when using a mixing nozzle

I finally understood why I am unable to calibrate my ext1 and 2 steps per mm. Found this in an older config file:

#define NUM_EXTRUDER 3
/** Set to 1 if all extruder motors go to 1 nozzle that mixes your colors. In that case only
steps per mm and heater manager settings in extruder 0 are used! */

I'd like to be able to calibrate them independently, as they all use home made hobbed bolts and they are not identical.

For now I'll define separate slic3r "filament settings" for each extruder, so I have a workaround. But it would be best if I could have just one "filament profile" per type of filament instead of having 3 different settings for each type of filament in the slicer.


  • I have just made an update that should solve the problem. Please report if it is working. I do not have a mixing etxruder for testing. Could only test if it compiles.
  • Works well.
    Thank you very much.
  • Hello, I'm sorry - I have the same issue - I'm using a mixing extruder but with different motor types and would like to set steps per mm for each - rather than have the steps per mm default to the setting for E0. You mention a fix, but I need a bit more help I guess. How do I set these steps per mm separately while using a mixing extruder?
  • 1. Use dev version
    2. Just set steps per mm for each extruder. It now uses the values from all extruders and not just from first extruder.
  • Wow, that is very simple! Many many thanks for your quick reply.
Sign In or Register to comment.