false heater decoupled

I got my machine running... good first layer height.... i'm soaring under the sky's of joy

BANG

i see this: 

14:42:23.414 : Error:One heater seems decoupled from thermistor - disabling all for safety!
14:42:23.414 : Error:Temp. raised to slow. Rise = -5.22 after 13078 ms

it comes very random... i have checked the termistor... 

i did PID tune for both bed and extruder... its an e3d all metal one with a resistor as heater.... and type 1 thermistor

both resistor and thermistor is attached with fire cement... no chance they fall out...


to make it more odd this "error" is there so short that i cant see any sudden drop in temp

are there any settings i can tweak to give it just a bit more time before it triggers?

Comments

  • it happened again... it a bit random...

    same ms number but much lower temp

    could it really be noise from  a fan? i use an all metal hotend...

    power wire is flat ribbon cable so i cant twist it.... are there any ways to check if its the fan? maybe disconnect it and try a small print?
  • This is happening in heat up phase where it raises from room temperature to target temperature. After 13 seconds of heating it reduced temperature by 5°C. Does this make any sense to your procedure? If you are printing a layer, then it shoudl already be up to temperature or are you using dual head with cooling inactive extruder down?

    Some users had problems with fan cooling the nozzle too much when it got enabled. In that case the fan was pointing too much on extruder and not on print.

    You can set timeout to 0 disabling decouple check or increase timeout that it would also catch a fan if that is the reason.
  • No it happens after heatup

    it started out with one of these bed level print that prints small squares that you can check to see if they are all the same and correct thickness... it prints a few squares and then suddenly filament gets thinner and thinner until it just moves the print head

    i then kill the print and raise up the nozzle turn the heater on again and try to extrude manual.... at this point i shows the error and i have to reset the printer

    the only fan running at this point is the one that cools the fins on the hotend... 

    very strange ... 

    my plan is to first disable check and run the test print while i can be next to the printer...

    if it works then enable it again and try with higher timeout

    what are the defines to change? just so i change the right ones
  • found this one:

    #define EXT0_DECOUPLE_TEST_PERIOD 12000
  • so set to 0 to disable and increase to account for a bit of noise etc?
  • btw.... when i do a G32 S2 i always end up with wrong 1st layer height...

    its about 0.2mm to high up... i have tried to set probe height to 0 as my nozzle is my probe... and i have tried with 0.5

  • and i have also experimented with Z lenght.... no matter what i end up with about 0.2 to high
  • here is how i do it:

    1. flash firmware
    2. M502 to delete old eprom settings (just to be safe)
    2. Home X and Y and place Z about 10-25 mm over bed
    3. G32 S2
    4. M500 to store everything (again just to be safe..)

    i then then place a steel feeler blade under the nozzle and lower it until it grips it....

    i always end with about -0.2

    i use a steel blade for old spark plugs... i think its better than paper and i can reuse it :-D
  • now its 0.2 the other way... ie its now 0.2 to much so i have to raise 0.2 to get it right
  • edited December 2015
    "If you are satisfied and if you have a z-max endstop you can also send a “G29 S2” to measure the print area height and store it in eeprom (S1 will only measure the height)."


    could that be used to messure the height from how the printer see things? ie do a G29 S1 when i know its close to right?
  • edited December 2015
    think that did the trick...

    i have set my z height to 0 as the nozzle is the probe...

    i then did a G29 S1 and took the height from there and put it in firmware

    then flashed firmware and did a M502 to erase old settings

    then G32 S2....

    now the error is down to 0.02... much less... rest can only be done by printing 

    i think that will be tomorrow.... could really use a reply on if i got the decouple disable right... 

    ie #define EXT0_DECOUPLE_TEST_PERIOD 12000

    set to 0 to disable and increase to allow a bit more noise etc...

    of course will monitor temp while i do it
  • no loose connections


    but maybe some noise?
  • You are confusing me with cross posts:-)
    G32 will delete previous G29
    All your switching eeprom from config to eeprom and overriding make everything only worse and is absolute nonsense misuse of the feature. Do this only once if your eeprom is compomised somehow. Then only change values and if they are better update your config for future. Since you have good value snow why copy them forth and back all the time deleting eventually working data. 
  • boelle said:
    found this one:

    #define EXT0_DECOUPLE_TEST_PERIOD 12000

    I had the same problem, after upgrading MELZI to RAMPS 1.4 (Wanhao/Maker Select V2)...

    Bumped to 14000 - same problem.

    Increased to 16000, and no more decoupling (for now).


Sign In or Register to comment.