Problem with enabling laser on Rumba

edited November 2015 in Repetier-Firmware

trying to get laser working on a Rumba board.

We tried enabling the laser, and set the #define ENABLE_LASER to 1 and tried different LASER_PIN options.
LASER_ON_HIGH is set to 1. DEFAULT_PRINTER_MODE is set to laser (1).

First tested was HEATED_BED, afterwards we also tried HEATER 1. While the commands seem to work (like the M3 command for example) the outputs don't produce any voltage so our laser doesn't turn on.

Any recommendations for a pin that we can control?

Here's a link to the config we are currently using:


  • Please supply your testing gcode. It is important to enable laser mode with 
    and then laser only turns on during G1 moves IF e increases or M3 was send. As asoon as line is finished laser will turn off, or it would make a damage waiting there.

    And last of all it uses pin 2 so make sure that pin works to enable laser. You can test with
    M42 P2 S255

    and disable with
    M42 P2 S0

    But be careful it will be on constantly at same spot!

  • edited December 2015
    Thanks for the response.

    In fact we forgot to set the correct laser intensity using M3. Any value under 200 did not activate the laser. After setting the intensity to max (for testing) any G1 command enabled the laser correctly.

Sign In or Register to comment.