Turning off all heaters

How do I disable the new function to improve safety of turning off heaters when they do not appear to respond according to some definition in the code? 

I know the question will get asked: why disable the safety feature? 

I want to disable the feature because the settings do not appear compatible with my printer. After a print is complete and the extruder is still warm I try to start a new print and it always fails out within 5 seconds. That is not long enough to determine if the extruder heater is functioning correctly, IMHO. I have to waste time resetting everything for it to work again. 

I suspect a bug in the host or firmware, but since I don't know enough about it I just want it turned off for now. I haven't burned anything since building the machine in 2012. But, also own a toaster, oven, microwave, gas stove (!), coffee pot, and clothes iron and can operate those as well without burning the house down so I have an advantage of experience with hot tools.

Thanks for any help with this issue.


  • More information about the issue in the figure. I really think it is a setting or coding issue.image

  • Hello? Anyone here? 
  • I have recently changed a thing in decouple testing, so it could be removed. Anyway, dsiabling is not possible but you can set values that would never trigger


    /** Time in ms between a heater action and test of success. Must be more then time between turning heater on and first temp. rise! */
    #define EXT0_DECOUPLE_TEST_PERIOD 1800000

  • I made the adjustment and it seems to have corrected the issue. Thank you for taking the time to help.
Sign In or Register to comment.