I need a little help with my Delta.  I have calibrated the XYZ endstops, Diagonal Rod length, Horizontal Rod Radius, Alpha A/B/C and the Corr. Diagonal A/B/C.  Currently the printer prints with the correct dimensions.  It will print the Delta Calibration object from Thingiverse with the angles and dimensions exactly correct.  The extruder tip moves flat between the center and a point in front of each tower.  

However...  The extruder tip rises off the build plate between the towers.  The further from the center the higher off the build plate.  This causes poor bed adhesion for larger prints.  How do I correct for this?


  • Unfortunately I know exactly what you are talking about. That is a common problem especially after you cross the line between the towers. Recently I discovered that changing diagonal rod length changes this behavior, but then you need to correct horizontal radius to keep it level. Before you try in this direction store your eeprom settings so you can come back to what you have. I know how much work good calibration is and I had no time to investigate this in detail.
  • First, thank you for knowing what I am talking about.  I can't find a reference for this anywhere.

    I have iterated Diagonal Rod Length, Horizontal Rod Radius, Alpha A/B/C many times.  Unless the behavior is non-linear changing any of those from my current setting only shifts the problem.  In certain settings I can get the arc between two towers closer to flat but that makes the other side worse and also throws off the dimensions of the printed object.  

    If I did change diagonal rod length and it did help how would I adjust for the dimensional problems?
  • With all the nonlinear dependencies I can not say what causes which new error. Maybe best solution would be to use your good calibration and enable distortion correction and make a height map with G29. Then we would just fix height difference with z moves, I'm also not totally sure if this is a calibraion or mechanical issue. I just observer that it likes to happen in these 3 regions.
  • I am still struggling here.  I have read pages of repetier documentation and I can't figure out the distortion correction.  Some repetier pages say G32, some say G33 and you have suggested G29.  Can you please tell me which is the correct command for distortion correction for a Delta printer?

    Also no matter where I set the X1-Y1,X2-Y2, X3-Y3 coordinates the G29 command attempts to make the same measurement which produces the following errors.

    17:06:15.480 : Error:Bpos x square
    17:06:15.480 : Warning:Invalid delta coordinate - move ignored x:-5748 y:11497 z:1797
    17:06:15.480 : Warning:in queueDeltaMove to calculateDeltaSubSegments returns error.
    17:06:15.495 : Warning:moveToReal / queueDeltaMove returns error

    I have a delta with a radius of 150mm.  My last attempt was X1=10 Y1=10, X2=10 Y2=70, X3=70 Y3=70 which should easily be within the 150mm radius.

    I am sure it is something simple I have wrong in the configuration but I can't figure it out.
  • G33 is correct with latest firmware version, before a more limited version was available under G29.

    Your problem is that measurement points are outside reachable area. Divide the xyz by steps per mm then you see the real position it tried to reach. And not forget that eeprom values count not configuration.h.
  • I am not sure I understand. 

    The coordinates I specified are not outside the reachable area.

     I put the X1Y1/X2Y2/X3Y3 in the configuration dialog box which is labeled "mm".  Am I supposed to be specifying a position in steps from a home position?
  • Yes, there you set the coordinates the first time, later on only in eeprom. So if you uploaded a version without zprobe it may contain different coordinates. Positions are mm from origin (middle of bed).
  • This is still not making sense.  I put the number 10 into the box for X1 and 10 into the box for Y1.  These are well within the range of my machine but I still get the error.  If I want X1 to be 10mm what should I be putting into the dialog box?

    Is there some other way to enter the coordinates into eeprom?
  • Clearly I am not getting this correct.  I have tried editing the coordinates in the Repetier Host Software Configuration dialog box and then using M500 to save them.  I have also gone back through the online Firmware setup wizard and downloaded and reflashed new firmware. I have use M502 to load the config.h No matter what I do the machine always attempts to go to the same out of range coordinates.  How do I get the old coordinates out of the machine?

  • By the way if i use M205 to output the EEPROM settings they are changing as I use all of the methods above but when I use G33 the machine continues to move to a set of coordinates out of range.
  • OK so I think I figured it out.  the G33 command doesn't use the EEPROM values X1Y1X2Y2X3Y3.  It uses the value from the configuratin.h for "correction radius"  This is set in the initial setup and is not visible from the Repetier Host configuration dialog.  the value must be about <=2/3 of the max printable radius to keep the values legal.  

    Anyway when I changed the correction radius the G33 worked appropriately.

  • Great, you found out. Didn'T know you had distortzion correction on. Always thought you talked about G32 or the simple G29.

    Anyhow, G33 measures a rectangle with n x n points. Check extrapolate corners to get a bit bigger area. Then the outermost corners get extrapolated from surrounding values.
  • I would like to suggest adding the correction radius to the EEPROM values which can be edited from Repetier Host software.
  • Hi,

    Have you solved the problem?
Sign In or Register to comment.