Printer looses temps at start

Hi all,

I have a problem with my printer that drives me nuts. Frequently, not always, this is what happens when I print - no matter if from SD or from Octoprint (Hardware: Mendel90, Rumba, Full Graphic LCD, Raspi, Octoprint):

The print starts normally, bed heats up, printhead goes Zero on all axes, Z down again, waits for extruder temp and starts printing. And in this moment, all temperature targets (Extruder + Bed) go to "0". Printer prints but stops extruding after cold extrusion temp is reached. Another print missed.

You see the missing targets in the sreenshot, same is on the display: 210/0, 55/0 or so.

I doubt this is a hardware or host error, as it occurs when printing from SD as well as from Raspberry. I can't remember having this issue when I used Marlin Firmware (which I like much less wrt the display etc.).

Any thoughts on this? It's a PITA and leaves my very frustrated.



  • edited August 2014
    I should add I have a 24V, 350W AC Industry Adaptor, this shouild be enough for everything I have (1 extruder, MK3 heatbed 200 x 300).

  • edited August 2014
    ups, here's the screenshot
  • infinite upload of 226kB, sorry doesn't work.
  • My guess is that your gcode contains the commands to set temperatures to 0. With wrong slicer configurations these might get included while slicing which also explains why you have it for all ways of sending it.

    Search eg. M104 S0 or M109 S0 in your gcode whcih would set extruder tempt to 0.
  • But the same Gcode worked yesterday and didn't work today...
  • Can't say without having seen it, but as you described it I'm quite confident that there is a gcode setting it to 0 involved.
  • How can I post a file here? Here's the beginning of the print without any of the codes you mentioned. Problem is the SAME gcode file can work, but can also fail.

    M190 S55
    M104 S215
    G1 Z5 F5000
    M109 S215
    G92 E0
    M204 S9000
    G1 Z0.22 F7800
    G1 E-1 F1800
    G92 E0
    G1 X107.309 Y59.583 F7800
    G1 E1 F1800
    G1 X108.107 Y58.293 E1.07067 F1080
    G1 X108.469 Y57.827 E1.09817
    G1 X108.995 Y57.212 E1.13589
    G1 X109.412 Y56.771 E1.16417
    G1 X109.697 Y56.512 E1.18209
    G1 X110.554 Y55.792 E1.23426
    G1 X111.11 Y55.409 E1.26572
    G1 X112.245 Y54.74 E1.32712
    G1 X112.684 Y54.539 E1.34959
    G1 X113.613 Y54.158 E1.39641
    G1 X114.369 Y53.926 E1.43326
    G1 X115.604 Y53.648 E1.49222
    G1 X116.134 Y53.584 E1.51712
    G1 X117.275 Y53.505 E1.57039
    G1 X157.578 Y52.591 E3.44883
    G1 X172.927 Y52.601 E4.16401
    G1 X174.395 Y52.736 E4.2327 F1080
    G1 X174.869 Y52.831 E4.25523
    G1 X176.385 Y53.245 E4.32847
    G1 X176.595 Y53.328 E4.33898
    G1 X177.75 Y53.825 E4.39756
    G1 X178.222 Y54.088 E4.42272
    G1 X179.442 Y54.877 E4.49045
    G1 X180.588 Y55.858 E4.56072
    G1 X181.023 Y56.321 E4.59032
    G1 X181.898 Y57.388 E4.65463
    G1 X182.689 Y58.666 E4.72466
    G1 X182.989 Y59.29 E4.75692
    G1 X183.52 Y60.664 E4.82553
    G1 X183.872 Y62.144 E4.89644
    G1 X183.95 Y62.757 E4.92523
    G1 X184.019 Y63.655 E4.96718
    G1 X184.031 Y64.044 E4.98533
    G1 X184.021 Y131.413 E8.12443
    G1 X183.876 Y132.921 E8.19502
    G1 X183.532 Y134.385 E8.26509
    G1 X183.295 Y135.059 E8.29837
    G1 X182.899 Y136.003 E8.34605
    G1 X182.536 Y136.685 E8.3821
    G1 X181.797 Y137.839 E8.44592
    G1 X180.985 Y138.812 E8.50497
    G1 X180.635 Y139.184 E8.52879
    G1 X179.52 Y140.151 E8.59755
    G1 X178.889 Y140.591 E8.63341
    G1 X177.882 Y141.194 E8.68807
    G1 X177.318 Y141.46 E8.71714
    G1 X176.084 Y141.947 E8.77894
    G1 X175.628 Y142.074 E8.80101
    G1 X174.605 Y142.314 E8.84996
    G1 X173.871 Y142.415 E8.88451
    G1 X172.725 Y142.495 E8.93804
    G1 X132.422 Y143.409 E10.81647
    G1 X116.916 Y143.389 E11.53898
    G1 X116.131 Y143.327 E11.57564
    G1 X115.4 Y143.227 E11.61005
    G1 X113.919 Y142.86 E11.68112
    G1 X113.405 Y142.672 E11.70661
    G1 X112.115 Y142.105 E11.77229
    G1 X111.779 Y141.913 E11.79033
    G1 X110.484 Y141.065 E11.86246
    G1 X110.29 Y140.906 E11.87414
    G1 X109.366 Y140.097 E11.93134
    G1 X109.02 Y139.73 E11.95485
    G1 X108.207 Y138.758 E12.01391
    G1 X107.874 Y138.265 E12.04163
    G1 X107.124 Y136.965 E12.11157
    G1 X106.473 Y135.312 E12.19436
    G1 X106.122 Y133.824 E12.26557
    G1 X106.05 Y133.243 E12.29285
    G1 X105.979 Y132.325 E12.33577
    G1 X105.969 Y131.956 E12.35296
    G1 X105.979 Y64.587 E15.49206
    G1 X106.127 Y63.06 E15.56353
    G1 X106.478 Y61.581 E15.63436
    G1 X106.704 Y60.942 E15.66594
    G1 X107.011 Y60.201 E15.70332
    G1 X107.276 Y59.65 E15.7318
    G1 E14.7318 F1800
    G92 E0
    G1 X137.202 Y118.491 F7800
    G1 E1 F1800
    G1 X137.202 Y131.947 E1.62699 F756
    G1 X137.142 Y132.703 E1.66233
    G1 X136.967 Y133.433 E1.6973
    G1 X136.68 Y134.126 E1.73226
  • No uploading support in this forum. Use services lik epastebin for this.

    I agree that there is no temp 0 setting in this code. Have you checked the log if a defect was triggered somehow, whcih is the only other reason I could think of, why it resets to 0.
  • My printer has a log? Where?
  • I have now printed from my laptop with Repetier host. First print worked, second print: Temps to zero in the second the printer started printing. Here is the log:

    I cut the First print and the end with many waits...

    Hope this helps, Ralf
  • What version is the firmware. Looks rather old since temp. output does not tell target temperature. That make sit hard to see where it got turned off. In fact I think it got already turned off, where the log begins since there was no output set.

    Maybe updating to a recent version would help.
  • Hi,

    The startup screen says "Version 0.91". Is there any way to see this more details of the firmware e.g. in the Arduino files?
  • Isn't that what you were looking for:

    > 15:19:57.134 : T:30.42 B:104.44 B@:255 @:0
    > 15:19:57.930 : Echo:M190  S105
    > 15:19:57.930 : ok 41358
    > 15:19:57.930 : TargetExtr0:235
    > 15:19:57.930 : Echo:M104  S235
    > 15:19:57.930 : ok 41359
    > 15:19:58.039 : ok 41360
    < 15:19:58.039 : N106906 M117 ETE 4h 32m 43s *44
    > 15:20:53.903 : Echo:G28
    > 15:20:53.903 : ok 41361
    > 15:20:53.903 : Echo:G1  Z5.00 F5000.00
    > 15:20:53.903 : ok 41362
    < 15:20:53.903 : N106907 M117 ETE 4h 32m 43s *45
    > 15:21:41.873 : TargetExtr0:235
    > 15:21:41.873 : Echo:M109  S235
    > 15:21:41.888 : TargetExtr0:0
    > 15:21:41.888 : TargetExtr1:0
    > 15:21:41.982 : ok 41363
    > 15:21:41.982 : Echo:G90
    > 15:21:41.982 : ok 41364
    > 15:21:41.982 : Echo:G92  E0.0000
    > 15:21:41.982 : ok 41365
    < 15:21:41.982 : N106909 M117 ETE 4h 32m 43s *35

    The thing I don't understand is highlighted in bold: Target Extruder 235, then 2 lines on Target Extruder 0. Strange.
  • Hi, I'm one step further: I switched to Marlin firmware and the problem is gone. So it must be a (I suspect a configuration) problem with repetier. Is it OK to upload my configuration.h here so someone with knowledge can have a a look?
  • Maybe I should add that I urgently want to come back to Repetier firmware as the meus are way better :-)
  • I have the same problem. I just tried it 15 times and it finally worked.
  • I switched to Repetier Firm 0.92 and never had that problem again.
  • What version? What does the log say? Is there a hint that it went into dry run when it happens?
Sign In or Register to comment.