Bed auto leveling and -2.1mm offset

I use Repetier Firmware 0.92 on my XYZ da Vinci 1.0A. I just have successfully run the auto calibration and got the following results:
Z 1: -1,839 mm
Z 2: -1,840 mm
Z 3: -1,848 mm
I tried to print a quick example but had to do an "Emergency Stop" because the nozzle was hitting the bed. 

So I checked the offset and it was 2.10 mm (to the correct bed Z position).

I do not want to configure this offset with e.g. Repetier-Host or other software. To clarify misunderstandings: I had to lower the bed for 2.10 mm.

Which setting (firmware side) do I have to adjust in order to get correct results when printing with 0 offset (software side)?


  • In eeprom settings modify z probe height by 2.1 mm. That is the height of the extruder nozzle above bed when the z probe triggers.
  • edited December 2015
    I just played around with Z Probe Height. It was on (+)0.540 mm. I set it to (+)2.640mm and the extruder nozzle hits the bed like always. I tried -2.640mm with the same result. Just for "fun" I tried (+)10.540mm and got the same result.

    I also (in addition) tried all those combinations with "Load <- EEPROM" after each "fix" done by Repetier-Host (Firmware EEPROM Settings). The very same results :(



    Seems like this setting does not have affect at all when do printing.

  • Did you recalibrate after changing? The value only changes the result of G32/G30 so only changing the value does nothing until next calibration.
  • Thanks! I will try another calibration...
  • edited January 2016
    So I did another calibration (two to be percise). The only changes are on the value displayed on the Z[1-3]. Having "Z offset" with Repetier Host at "0" and "Z-probe height" with Repetier Firmware at +"1.89" (or the other way at "-0.81"), the nozzle is hitting the bed when printing the exact same way as before.

    Again: just the display values changes when doing "Auto level bed". The nozzle hits the bed when printing as always.

    Maybe I misunderstood you. That is why I be most descriptive with this post.

    To have the best printing results I have changed "Z offset" with Repetier Host to +"1.35" mm. I want to have that "0" and Repetier Firmware is "fixing" this Z offset for me.
  • For your interest. Latest 0.92.8 has a reworked autoleveling with also more possible combinations for measurement like grid. 
Sign In or Register to comment.