Z probing with extruder nozzle


I built an extruder mount that enables the extruder nozzle tip to be used as probing point.
The extruder is mounted on a hinged plathorm. As the nozzle goes down, pressing against the plathform, a limit switch is triggered (Z probe is triggered). Image below explains the principle.image
imageThe problem is that the triggered probe point is actually below the Max Z height of the printer.
Repetier seems to have a problem accepting this.
Also, setting the Z probe height to a negative value does not solve the problem as the levelling sequence is cancelled by setting when setting a negative height.

Is there any way to solve this? Some short directions might help me change the firmware.
Also, this might be a good option to add to the firmware. This way of levelling has some advantages:
-Measure Z height as the nozzle itself, thereby reducing errors
-Compensate for nozzle expansion when nozzle is heated. Expansion is different fro PLA vs ABS temperatures
-No deploying or retraction scripts needed. 

Thank you!,


  • Please try latest 0.92 version. There I fixed the problem of going below 0. This is now allowed for z probing.
  • I want to ask about?
    "If you have some trick to enable/disable a z-probe, you can write the required g-code commands in Z_PROBE_START_SCRIPT and Z_PROBE_FINISHED_SCRIPT. Multiple commands are separated by a \n."
    I wrote this script here: Z_PROBE_START_SCRIPT "G1 x15 y15 Z30 F3000 \ M104 s210"
    but there are only the first team the following does not work. why ??

  • I guess your problem, SONIC300077, is that small letters are not acceptable gcode. They are usually capitals.
  • I would omit the extruder heating. It will not wait for heatu anyway, so probing would start still cold. So heat up before you probe. Anyhow, your string only contains \ and not \n to separate commands. Letters shoudl also b eupper case also I think latest repetier can handle lowercase as well.
  • I have a related problem. I am trying to get a Solidoodle Press running with Repetier Host.  The probe hits the surface at about Z=5mm and isn't adjustable.   The probe later retracts.  I want to offset downward a given amount for my print from the probe signal.  I would measure by slowly stepping the head downward until just above the surface, then add the offset.  Even if I add a -5mm offset in Slicer, I can't get it to print under the probe stop.  Any ideas?
  • @tay not sure what you are trying. What is the realtion of z probing and slicer? z probing is for computing tilt and z positioning. Afterwards you should be able to run a normal print starting at z = 0.

    Also note that only latest 0.92.2 fixes a problem when probing starts above z max probe height.
Sign In or Register to comment.