ZLift with Firware Retraction bug

Hi guys,

I'm think I've found a bug in 0.94 firmware relating to Z Lift on firware retracts.

Retract actually works as I imagine it should, but on undo (G11) the Z move back toward the bed is actually performed during the first X/Y move (so it ramps down toward the table DURING the first X/Y movement instead of dropping down BEFORE the movement begins).

Anyone else using firmware retracts able to confirm? 


  • At least in the code it looks correct as it does not move x or y and only adds a pure z move:

        else if(!isRetract && isRetracted())
            if(zlift > 0)
                PrintLine::moveRelativeDistanceInStepsReal(0,0,-zlift,0,Printer::maxFeedrate[Z_AXIS], false);

    I assume you are talking here about 0.92.x firmware. Will test it when I get some time and think of it. It is at least not the intension of the code above.
  • yes, sorry, 0.92.4 i meant :-)

    Does that chunk of code actually spit out a "G1" as well? because if not (I'm unsure how this would actually be treated) the Z move may be performed in the next G1 block?

    It is much more noticable when doing simple objects (such as a cube) where the retract ramps a significant distance after a unretract.

    This was running from SD card, I had just used gcode and all worked as expected with firmware retracts, all I did was change the Z jump height in EEPROM from "0" to ".2mm" using the PC and then ran the code from the SD again with the bug that is in question.
  • The code adds a pure z move (x and y are 0), This is a separate move and next G1 should add one more move independently with the new Z height. Do you have autoleveling enabled? The move will apply rotations to the z move.

    I will test it with a exaggerated and slow move so I can see what is really going on. 
  • Thanks, I have switched it off for now as it was messing with a customers print but I will test and report any further findings. Watch the Z mootor carefully during z jumps.
  • Ok, I could reproduce the bug very well. Looks like I have solved it in 0.92.6.
  • Great news!

    I updated just the other day at work, to .92.5 - is .92.6 up yet / if not, when do you expect to put it up?

    Thanks for looking into it, really do see benefits to firmware retraction so I appreciate the effort ;-)
  • Ah I see, it's done. Downloaded for testing ;-)
Sign In or Register to comment.