Z motor stepper moves once only

Printer Prusa i3, board Melzi, firmware repetier 0.92.4. Manual control with repetier-host, X and Y move ok, Z moves just a little, only once. I have to shut down completely (USB and power supply), restart and then same behaviour.
Any advice ? Thanks.


  • Check acceleration (50-100) and steps per mm and max speed (2-5mm/s). If you are too fast you only hear a whining sound from lost steps and nothing happens. Check in eeprom!
  • Hello,
    After checking above points, i did'nt find the fault. I tried to modify various parameters, but no success.
    Please find EEPROM content here after :
    <?xml version="1.0" encoding="utf-8"?><Repetier-Firmware-EEPROM><epr pos="1028" type="0" value="255">Language</epr><epr pos="75" type="2" value="115200">Baudrate</epr><epr pos="129" type="3" value="0.000">Filament printed</epr><epr pos="125" type="2" value="0">Printer active</epr><epr pos="79" type="2" value="0">Max. inactive time</epr><epr pos="83" type="2" value="360000">Stop stepper after inactivity</epr><epr pos="3" type="3" value="80.0000">X-axis steps per mm</epr><epr pos="7" type="3" value="80.0000">Y-axis steps per mm</epr><epr pos="11" type="3" value="2560.0000">Z-axis steps per mm</epr><epr pos="15" type="3" value="200.000">X-axis max. feedrate</epr><epr pos="19" type="3" value="200.000">Y-axis max. feedrate</epr><epr pos="23" type="3" value="2.000">Z-axis max. feedrate</epr><epr pos="27" type="3" value="40.000">X-axis homing feedrate</epr><epr pos="31" type="3" value="40.000">Y-axis homing feedrate</epr><epr pos="35" type="3" value="2.000">Z-axis homing feedrate</epr><epr pos="39" type="3" value="20.000">Max. jerk</epr><epr pos="47" type="3" value="0.300">Max. Z-jerk</epr><epr pos="133" type="3" value="0.000">X min pos</epr><epr pos="137" type="3" value="0.000">Y min pos</epr><epr pos="141" type="3" value="0.000">Z min pos</epr><epr pos="145" type="3" value="200.000">X max length</epr><epr pos="149" type="3" value="200.000">Y max length</epr><epr pos="153" type="3" value="120.000">Z max length</epr><epr pos="51" type="3" value="1000.000">X-axis acceleration</epr><epr pos="55" type="3" value="1000.000">Y-axis acceleration</epr><epr pos="59" type="3" value="100.000">Z-axis acceleration</epr><epr pos="63" type="3" value="1000.000">X-axis travel acceleration</epr><epr pos="67" type="3" value="1000.000">Y-axis travel acceleration</epr><epr pos="71" type="3" value="50.000">Z-axis travel acceleration</epr><epr pos="1024" type="3" value="0.000">Coating thickness</epr><epr pos="880" type="0" value="0">Autolevel active (1/0)</epr><epr pos="106" type="0" value="0">Bed Heat Manager</epr><epr pos="107" type="0" value="255">Bed PID drive max</epr><epr pos="124" type="0" value="80">Bed PID drive min</epr><epr pos="108" type="3" value="196.000">Bed PID P-gain</epr><epr pos="112" type="3" value="33.000">Bed PID I-gain</epr><epr pos="116" type="3" value="290.000">Bed PID D-gain</epr><epr pos="120" type="0" value="255">Bed PID max value</epr><epr pos="1020" type="0" value="0">Enable retraction conversion</epr><epr pos="992" type="3" value="3.000">Retraction length</epr><epr pos="1000" type="3" value="40.000">Retraction speed</epr><epr pos="1004" type="3" value="0.000">Retraction z-lift</epr><epr pos="1008" type="3" value="0.000">Extra extrusion on undo retract</epr><epr pos="1016" type="3" value="20.000">Retraction undo speed</epr><epr pos="200" type="3" value="95.000">Extr.1 steps per mm</epr><epr pos="204" type="3" value="50.000">Extr.1 max. feedrate</epr><epr pos="208" type="3" value="20.000">Extr.1 start feedrate</epr><epr pos="212" type="3" value="100.000">Extr.1 acceleration</epr><epr pos="216" type="0" value="3">Extr.1 heat manager</epr><epr pos="217" type="0" value="230">Extr.1 PID drive max</epr><epr pos="245" type="0" value="40">Extr.1 PID drive min</epr><epr pos="218" type="3" value="7.0000">Extr.1 PID P-gain/dead-time</epr><epr pos="222" type="3" value="2.0000">Extr.1 PID I-gain</epr><epr pos="226" type="3" value="40.0000">Extr.1 PID D-gain</epr><epr pos="230" type="0" value="255">Extr.1 PID max value</epr><epr pos="231" type="2" value="0">Extr.1 X-offset</epr><epr pos="235" type="2" value="0">Extr.1 Y-offset</epr><epr pos="290" type="2" value="0">Extr.1 Z-offset</epr><epr pos="239" type="1" value="1">Extr.1 temp. stabilize time</epr><epr pos="250" type="1" value="150">Extr.1 temp. for retraction when heating</epr><epr pos="252" type="1" value="0">Extr.1 distance to retract when heating</epr><epr pos="254" type="0" value="255">Extr.1 extruder cooler speed</epr></Repetier-Firmware-EEPROM>
    For information, when z motors stop, the board still reacts ( echo of the commands) but no Z move. I must switch off the power and remove the USB cable, reset button does not react. After switchING power on and connecting the USB, i can try the z-move and i obtain this very short move (impulse) and nothing after that. Is it a security in the driver itself ( A4982)?
    Paul LINDEN
  • EEPROM looks fine. Is friction of axis low and motor current high enough? If the x axis is not horizontal you increase friction and that can block motors.
  • Still no solution ! I just installed an other Melzi board which i have as spare part. Behaviour slightly different : Z motors do shaked moves, randomly clock- or contraclockwise. I tried to change motor current, no success. After a few trys, board freezes and i have to disconnect USB and power before restarting, that's to say same behaviour as with the old card !
    I'm really unable to imagine a solution ! Please HELP !
    Thanks in advance for any hint !
    Paul LINDEN
  • Can you please tell something about your hardware?
    What type of control board you are using?
    Also what is your firmware and how you develop it?
    Can you please post the specifications of all your hardware including motors also?

  • Definitely strange behaviour !
    Just for fun, I just plugged Z connector on the X output of the board and the X connector on the Z out put.
    Using manual control of Repetier-host : clic on X move : Z moves , that's logic, but clicking on Z moves Z also !
    Any idea ?????

    For ElmaWebber : all details see the beginning of this thread !
  • Check in online config tool. For each direction you can select a driver socket. If you select x socket for z direction exactly that would happen. Maybe you changed it while scrolling the page?
  • I suppose some drivers are dead on my Melzi board. I just received a new board, Melzi design from Geetech. Connecting over USB with Repetier-Host (v1.5.6) i can connect but no command working. Serial Port is ok. Firmware and EEPROM are ok ( I downloaded the old original firmware with my Olimex interface). The screen displays some commands echoed from the board, but without signification. Every 40s ( settings for the printer) i have a communication time-out and resent send buffer block.
    Serial speed controlled : 115200.
    Any advice ?
  • Sure you see echo from firmware and do not have command output enabled? Sounds more like you have no communication at all due to wrong baud rate.
  • I checked the baud rate : 115200 in the printer settings and in the eeprom . As explained the installed firmware is a copy of the original firmware which worked well in the past. As i don't send any command in manual control mode, i can not explained the origine of the displayed codes. They look like a response of the board with line number, G or M code followed by a number and a *.
  • Host log looks exactly like that. You should be able to see if you have the switch enabled.
  • Ok. But this does'nt explain why i can not communicate with the board. May be a FTDI driver issue ?
  • If you can upload a firmware the serial driver is ok.

    How did you know value in eeprom is 115200 if you can not connect? Maybe it was 250000 on first upload. As long as you do not change EEPROM_MODE value old values stay. So maybe try with changed value and try again.
  • You are certainly right, there is an issue with the baud rate but :
    with my Olimex AVRISP-MK2 and using Atmel Studio, i can read, verify and upload the firmware as an .hex file and also read, verify and upload the eeprom content as an .eep file. The files i used are copy of the original Melzi board. You explained that i have to change the eeprom mode. This is what i do when compiling a new version of the firmware. But when uploading to the eeprom with my ISP, is it necessary to change the mode and how can i do this ?
  • Another information : i can control the board with the local keyboard and display of the printer (five button system). My peripherals manager says i'm connected over port COM6. But no response of the board.
  • Ok, if you have lcd you can even check your baudrate in configuration->general. So if this matches and port is ok then it could be a hardware problem. After all you are using a isp to program and not the bootloader and I wonder why you do that? Woundn't using the bootloader be faster? And if you use the bootloader you know that serial communication works.

    I hope you have not configured the server to connect to your printer? In that case the host can only connect over the server connector and not the port, at least as long as the server printer is activated.
  • Some news :
    - using the display i just checked the baud rate, it's ok 115200
    - using local commands (buttons near the display) i checked some eeprom values like accelerations, feedrate,steps per mm and so on. All values conform to the original eeprom.
    - Using local buttons for moves: X moves brutally, values greater than awaited. Y moves also with strange values. Z rotates a little bit in random directions.
    - I explored the FTDI issue as explained on "http://reprap.org/wiki/Melzi#Can.27t_connect_to_the_Melzi_.28FTDI_driver_problem.29" and the PID is effectivly 0000 instead of 6001 !!! This means that i have a counterfeited FTDI chip ! I suppose this explain strange behaviour of the board.
    Do you know a method how to restore the correct PID ? Thanks !!
  • Ironically FTDI provides a tool for this after deleting the ID with their in between driver version (so make sure to update to latest FTDI first). I forgot the name but if you google you will find it or from their tools section. It was a tool to analyse/program the chip where you could also set a id.
  • Did you find a fix?
    Im having same thing Ive used the default setting command for printer but I was at 25000 baudrate, when I saved it lost connection and wouldnt connect.
    I checked lcd for baudrate which had changed to 11520 so I changed repetier host and connected fine.

    I can move extruder with the lcd position and move E to 1mm it will start spinning like mad and not stop. I then press again and it does like 1mm movements then dies, cant control threw repetier host.

    With Z straight after a start up if I use manual control it will move, some times do same as Z, also had Y do it with manual control homing individual axes in XY and Z order.
    I can get Z to turn slightly in each direction and E to move with lcd.

    Tbh just changed Z steps per mm to 3200 and it is tighter but still not working.

    Ive done literally everything and stressed now.

    Is all of my experience so far im ready to give up again as this the 3rd time in 3 months ive dedicated many days to get no results.

    Why put a programme on a machine if it dont work.
  • Actually you seem to have lots of problems but your descriptions are so confuse and widespread that I can not make any sense of it. Apperently everything is working sometimes somehow and sometimes not. That sounds like you always hit some safety conditions like moving in direction of activated endstop which will not work, cold extrusion and such things. Be systematic in solving your issues and make easy to understand error reports so we knwo what exactly you did, expected and what happened.  Start first by testing all sensors especially endstops with M119, then check homing works in right direction. Then moves should work. Then test temperature readings and heating and then with hot extruder extrude. Check eeprom for changes to be made like steps per mm or accelerations. That is how all need to configure self made printers.
Sign In or Register to comment.