I can't get no extrusion :(

Hey guys and girls, 

I'm having some big headaches getting my i3 to print. Can't get the extruder motor to turn, I know there has been a number of discussions in this category relating to this and I've been through them and tried what I could. 


Extruder motor won't turn.

Troubleshooting steps:

Jogging extruder in host with M302 S0, no good.

Checked the motor wasn't stuffed-removed from the extruder and hooked it up to the X axis pin outs on RAMPS, worked perfectly.

Checked RAMPS and the driver by changing the pin numbers in pins.h-changed over X axis and E0. When I jogged the X axis in host the extruder motor jogged (correct) but when I jogged the extruder in host, the X axis didn't move. Used M302 to disable cold extrude prevention.

Modeled, imported etc a little cube and pressed print, it homed the axes, the hot end heated up and then it printed, did everything perfectly with the exception of extruding any material.

Not mechanically bound or jammed.

Makes me think software/firmware so;

Extrude temp is set to a reasonable value #define EXTRUDE_MINTEMP 150

I tried setting it to 20 degs (less than room temp) then running a print/jogging with no filament-no good.

Tried commenting out the dangerous extrusion option.

Tried inverting the stepper enable pins from 0 to 1, no good.

The last comment in this thread 

Has me curious, I can't find a simple "enable" setting, but I'm pretty sure all my host settings are okay.

Tried printing with and without "dry run" selected.

Played with the feed and acceleration settings, only a couple tried 10mm/s, 25mm/s and 10000 mm/s^2 and 5000mm/s^2 ( this is the most recent thing I've been trying, so still trying to get some ball park figures for these parameters)

Fairly certain I'm using V1.5.6, there are a lot of (recent) posts discussing V0.92, not sure that the software would have progressed that rapidly in such a short timeframe (posts within the last couple of days talking about using 0.92). So I'm slightly worried I've mucked something up with the versions??

Long story short, I know the motor works, I know the board works and the driver works. Firmware or software isn't telling the motor to turn.

Sorry for epic post, just trying to be thorough (while probably rambling somewhat) 

Any help is greatly appreciated, I'm thinking it's going to be something simple and stupid. Just throw ideas at me please!!!! 

Thanks :) 


  • Additional info:

    Using Marlin, Repetier (obvs) RAMPS 1.4 all the standard stuff.

    The fan isn't hooked up yet (is there a "fan must be on to extrude" setting?)

    Similarly, disabled hotbed just cuz I don't want to wait for it to heat before each trial print (is there a "hotbed must be at temp to print" setting?) Disabled it in host with the strikeout option.

    Also, when I try a print and the hot end heats up, my logs say:

    T:76.5 (for example) E:0 W:?

    Could the E:0 and the W:? be indicative of something?

  • Extruder motor is hot!!!

    Perhaps it's getting a signal after all....

    Driver pot setting???
  • Okay so when I connect to rep, the motor squeals, heats up and also locks up (I can't turn it by hand). It's pulling between like 0.5 and 2.5 V across a pair of "windings" I guess you could say, maybe phase is the better term.

    So even though I haven't commanded it to do anything, it's trying to run and sort of jamming. Pot rotation does nothing other than increase the voltage and change the noise it makes.

    It gets deeper :/

  • Is the motor blocking from beginning? If so, you have inverted enable signal so it gets off while turning and on while disabled.

    If it whines while extruding you steps per mm or acceleration is set too high. Often a dot got removed somehow.
  • Thanks!!!

    I did try toggling the invert setting, but I'll have another crack. 

    Will report findings ASAP :)
  • Repetier, thanks for commenting.

    You were right about the invert enable. Toggling that between 0 and 1 was one of the things I was using to debug, so the 1 setting was still on the eeprom when I was describing the symptom of the motor being "on". Once set back to 0 it doesn't do anything when at idle and continues to do anything when it's told to.

    My process for debugging is pretty much:

    Make a change (guess/stab in the dark at this point) in the firmware, upload, connect with Host, M302 S0, then I attempt to jog the extruder 10mm with the button in "manual control" that points to about 7 o'clock. 

    Does this sound like a reasonable way to attack it?

    Any other suggestions?
  • Can't edit the above:

    "continues to do nothing when told to" not anything :/

  • Just updated firmy to 0.92.5, uploaded, connected and still no luck.

    Going to catch some z's and try again later :)
  • Got it working, changed to E1, so wiring connector to motor, driver all over to E1 and then just changed the pin numbers in pins.h, swapped the numbers between e0 and e1.


  • Great. So something with E0 is defect. In these cases a extra driver port is always great.
Sign In or Register to comment.