Extruder motor vibrates but does not move.

edited October 2015 in Extruder & Bed

I have a ramps 1.4 with arduino mega 2560. Everything works with Marlin firmware.

With Repetier (versions .91 and .92), the extruder motor just makes a buzzing sound, vibrates (I can feel this vibration even in the filament) and appears to be stuck in place.

The extruder is heated, moving the axis also works fine, homing, etc.

Already tried reversing wiring, tested wiring, replaced stepper driver, tested with another motor, pretty much everything.

I have another control board (MKS-BASE), that runs fine in the same printer with Repetier Firmware.

Anybody having a similar issue?


  • Since it worked in Marlin I guess your start feedrate/steps per mm/acceleration/speed is wrong. Check eeprom settings for it. If you are to fast the motor gets no force and just looses steps.
  • Thank you very much!

    For some reason, when I set up my steps per mm in the firmware configuration tool, 632.271 became 632271!

    Fixed it in the EEPROM, and now everything works!
Sign In or Register to comment.