Z-probe and autoleveling on my mendelmax 1.5 need help

edited October 2015 in Extruder & Bed
Hello, I want to upgrade my printer with z-probing/ autoleveling bed, because I have to adjust the heated bed very often,..... So I made a new configuration in repetier-Firmware config tool and upload it to my ramps 1.4. i also install servo on the board and make it run with manual command.

When I send G32 S1  via RH program to te printer, printer is making 3 point measuerment but with no servo extraced,.... Please see the video below in the link. What am I doing wrong?? Please also see my configuration.h file. (ps i've got Z_min endstop for Z homing and Z_max for z_probe)




  • Your problem is this:

    #define Z_PROBE_START_SCRIPT ""
    If you do not tell it needs to activate a servo it will not do it. Add the right servo commands in start/end and it will do this.
  • Could you please point me to this commands for servo to operate.

  • M340 P<servoId> S<pulseInUS> R<autoOffIn ms>: servoID = 0..3, Servos are controlled by a pulse with normally between 500 and 2500 with 1500ms in center position. 0 turns servo off. R allows automatic disabling after a while.
  • edited November 2015
    Hello, Still got problem, I followed the instruction that are on RH site:

    Verify z-probe

    Before you risk any damage, you should test, if you have configured the z-probe correctly. Run a


    check the signal of the z-probe. It should be low/off. Now trigger it
    by hand and send the command again. Make sure the signal is now

    When I run G31 command I get Z-probe state:H, when I trigger my switch and send the command again i get the same result-> Z-probe state:H

    Does this mean that I wired microswitch wrong to the board or something else? (please see the picture of the ramps, where I wired my switch)

    thanks for reply

  • If it is a mechanical switch, make sure you have pullup enabled and do NOT use that pin for a endstop pin. Some users configure zmin since they put it in zmin, but that is wrong. It is z probe connected to z min pin. Therefore you set the pin number for the z probe and also pullup independently.

    After it switches sign, make sur eit is L when not triggered.
  • It is mechanical switch, so I connected it the wrong way? On what pin on board I must connect this switch to make it work? Please paste some pictures.

  • edited January 2016
    Hey igli, not necessarily. It may be connected correctly, just check any description of your board (RAMPS I assume?). It is ok to put the probe to the z_max pin as you did. If its a simple switch with two wires, one wire goes to ground (the middle pin) and the other goes to "S", which is the uppermost pin (or the pin nearer to the PCB edge). See here: http://reprap.org/mediawiki/images/c/ca/Arduinomega1-4connectors.png
    Which wire goes where doesn't matter, you can mix them up.

    Again: Do not define z_max as an endstop pin, but solely as a z probe pin. Then activate pullup (pullup enabled) and test your G31 again. Also, perhaps you will have to invert your signal, which is also done in configuration (G31 has to report back "L" when not triggered).

    That should resolve your problems.
Sign In or Register to comment.