Two Y Steppers - Only one disables

I've got a cartesian printer with FEATURE_TWO_YSTEPPER enabled. Appears to work fine, but I can't get the second Y Stepper to disable. 

When I disable the steppers, X and Y1 disable but not Y2 so I'm unable to move the gantry by hand. I've got Z set to remain enabled at all times to keep the bed up. 

I've got a somewhat unique setup in that I'm also running dual Z steppers, so I had to use Aux 2 on the Ramps board to run Y2. So my configuration.h looks like:

#define Y2_STEP_PIN              ORIG_Y2_STEP_PIN
#define Y2_DIR_PIN                ORIG_Y2_DIR_PIN
#define Y2_ENABLE_PIN         ORIG_Y2_ENABLE_PIN

 In the pins.h file I setup:
#define ORIG_Y2_STEP_PIN       42
#define ORIG_Y2_DIR_PIN         40
#define ORIG_Y2_ENABLE_PIN  63

I have DISABLE X/Y/Z/E set to false, so I'm disabling the steppers through the LCD or an M84 command. 

What am I missing..?


  • Updated to 1.0.4 using the configurator tool. Whatever the issue was (probably improper config on my part) it’s working now.
Sign In or Register to comment.