X Homing Not Working

Hello, I am completely new to this technology and have been tasked with troubleshooting a problem at my job. I am having an issue with homing. We are using Repetier Host and a RAMPS board to control two stepper motors for a membrane welding machine. The motors move the machine down a long table in a single direction, so the only direction being used is X, not Y or Z. Scripts specifying motion in the positive X direction work fine, but homing X has stoppped working. This is both using the actual X home button as well as the code G28 X0. When I try either, the motors briefly turn in the wrong direction (away from home) for a second then stop, no matter where they are along the X axis. We are using magnetic proximity sensors for the endstops and they seem to be working fine. The malfunction happens regardless of the state of the endstops. The problem seemed to come out of nowhere; nothing in the configuration or firmware was changed as far as I know. Also, when I try M119, absolutely nothing happens. Not sure if this is related. 


  • Homing is done inside your printer firmware and independent of the host. So the solution is firmware or if it is the same that was working it might be a hardware defect. What you describe would typically happen if the x endstop is always triggered. Move in wrong direction is the back move after first hit before tesrting again. Enable log/console (easy mode off) and send M119 to see end stop state. If it shows high without being triggered that is your issue.
  • When I sent M119 I got the following code:
    endstops hit: x_min:H  z_min:H
    This is with the x endstops not triggered. When I trigger the endstops and check again I get the same message. Seems like the endstops being triggered is not getting picked up by the hardware/software.
  • Yes, exactly what I thought. x_min should be L when not triggered and H when triggered. You can measure the output voltage of the endstop and see if it changes. If not the sensor is just defect. Also check if cable is ok or broken on the way to the board.

    If it never worked before it might also just being wrong pin compared to the one you defined in configuration.
  • The endstop signal measures 5V when not triggered and 0V when triggered. I measured from the endstop itself as well as where the cable plugs into the board. It seemed to work fine for years then all of a sudden stop working a few weeks ago. The endstop was replaced with a new identical unit but didn't solve the problem. 
  • I've tried changing Xmin inverting to true and pullup Xmin (not sure what this does) to true but these don't have any effect. 
  • Found the problem! You were right, connector was plugged into the wrong pins on the board. Thanks for the help.
Sign In or Register to comment.