Resurrecting printer with Gen7 board

Humble greetings,

I attempt to resurrect my RepRap 3d printer that I built over 12 years ago. Originally it was running on Teacup firmware on a Gen7 1.4.1 board but seeing Repetier's superiority I wanted to give it a go.

I am fully aware that this is an ancient tech, thought the board was supported and it seems it still should. It runs an AT Mega 1284P at 20 kHz.

The board communicates through USB serial port from FTDI:

  • 115200 bits per second

  • 8 data bits

  • None parity

  • 1 stop bits

  • None flow control

Following instructions I used Arduino IDE version 1.0.3, installed boards with Gen7-Arduino-IDE-support, downloaded Repetier firmware version 1.0.4 (with triple checked settings), corrected one little issue with c++ code (prev Arduino gpp does not include lroundf function).

Code compiles, BAUD-rates are same, I upload all to the board, start listening to the port and… get semi-garbage:



I could really use some guiding directions to what I might be missing.

To jump ahead of extra questions: I tested earlier and newer versions of Arduino IDE, I tested older versions of Repetier, I changed BAUD rates, toggled other properties of serial port.

Here is link to git repo with Gen7-Arduino-IDE-support and my config of Repetier firmware.


  • Try selecting a new EEPROM_MODE value so after upload config values are forced to take over. This looks either like wrong baud rate or a memory issue. The other thing might be flash memory. If I remember correctly the 1284 has only 128kb ram, so check arduino output if it shows less flash usage. Also text block must be below 64kb or you might see code or wrong text instead of the text it should point to, so eventually remove some translations or other features to reduce memory usage to what the processor can handle.
  • Thank you for your answer!
    I read somewhere that Gen7 does not support EEPROM, though I will look into it.
    Unless my cables are bad, the transmission should be OK, I tested with 4 different baud rates. Regarding memory - as far as IDE tells me, the package should have around 74kb of 128kb (the biggest package I tried was 86). I am not sure about the text blocks, where can I check the size?
  • The eeprom is on the avr1284 chip so think it should have eeprom if you enable it (mode not 0). Text usage is visible where you also see ram/flash usage, but maybe older ide would not output it. With 74kb total size you have no issue with that. Problems only come if you have lcd support with multiple languages because each language takes lot of space.
  • I made some progress - really appreciate your support.

    While I (wrongly) thought the total size might be the problem, I tested the older versions of the Firmware.
    Switching to Repetier 0.91 rev8 using Arduino 1.0.3 and Gen7-Arduino-IDE-Support-2.1 did the trick! The printer started to move using Pronterface 2.0.1.
    All but the extruder motor...

    I checked the board for damage or short circuits, verified that the motor works, checked that Pololu motor driver works, still no response of Extruder motor.
    I also tried Repetier 0.92, but interestingly enough the motors stop responding, though arduino ide serial monitor seems to get nice responses.

    Any ideas what could be the issue?
  • Did you heat extruder? Depending on config you need a minimum temperature for the extruder motor to move.
  • Yes! That did the trick! Thank you! I am off to calibrate it and start first print since ever!

    Last curiosity regarding the version upgrades - I know that there were multiple improvements since 0.91 through 1.0 and 2.3, and I would love incorporate at least some of new features. Still, even firmware upgrade to 0.92 stops the printer, and 1.0 produces garbage. I assume this has sth to do with old Gen7 Arduino board definitions being incompatible with 0.92. I thought that drivers just deals with pinouts, while firmware should be "logic" (and that stays constant). Could you direct me to where can I look, or what should I re-implement to possibly get newer Repetier running?
  • Isn't gen7 using the sanguino arduino board definitions? That needs to be installed additionaly to ide and be selected as board in arduino ide since it was not included as official board. That would be the only thing I can think of. Haven't changed board definitions as far as I can remember, but once my gen6 fried I had no test board any more. But firmware ha salso some hardware dependent stuff for timer programming, adc conversion and faster pin toggling then the arduino ide functions did which were to slow for firmware. When 0.92 alread does not work with same config there might be a change making it fail. 

Sign In or Register to comment.