Heatbed temperature copying extruder temperature.

edited November 2023 in Extruder & Bed

I have a melzi board 2.0 board that was working fine , now I have a problem with BTEMP readings, it is copying the ETEMP readings.

I can turn on and heat the bed and it's working fine but temp won't change it will remain the same around 40 degrees.
When I turn on the extruder, the heatbed temp will read the same values.

Replaced the capacitor and resistor near Btemp pins, problem remains.

I suspect a short somewhere but noob in electronics can't guess where to inspect.

Tried to change Btemp/Etemp sensor pins in the firmware , to X Y Z endstops , heater and bed temps read 350 degrees at rooms temp or when nothing is plugged.

is there a solution for this ? someone told me this Analog to digital conversion issue , would replacing the chip fix this issue ?



  • You can not simplz switch pins for temp. sensors. The analog pins have also a 4.7k resistor in series so the measured voltage behaves completely different to a pure analog input. You can only switch between the temperture sensor pins, so if you have 2 extruder sensors you can use one for bed instead. If you use a different analog input see schematics on how to connect the resisitor and sensor correctly using a 4.7k resistor.
  • edited November 2023
    thanks , ordered a BTT SKR mini e3 v2 for replacement, can I flash Repetier to this board ? Repetier worked well on the melzi board, I want to to keep the same experience.
  • V1 is not compatible, because it uses a different cpu. Our V2 version can handle it I think, but there is no config tool just the dev2 branch on github and a documentation. It works like a meta language for programming a printer with modules building the software.
Sign In or Register to comment.