Z goes too up after homing


I got my first 3D printer recently, and I tried to make it work. It's a GeeeTech I3.

My issue is, when I'm homing all the axis, they work perfectly. I configured the Z axis to be just high enough above the bed to be able to let a paper sheet goes between them.

But when I'm starting to print - I'm using Slic3r -, the axis gets homed, and when the Z axis touch its "stop" button... It proceed to go ~5mm too much above the bed. What can I do? I tried to change the Z offset from the Slic3r printer menu, but nothing changes (I did put -5)

Thank you in advance for your help! :) If you need more informations, tell me!

Best regards,



  • ps : I looked everywhere I could, I don't see the same issue I have anywere. Or my keywords are wrong/bad, also a high probability..
  • Wrong position for question I think. Question is first who does the error. If sending
    has nozzle at good position and in console you see z = 0 then firmware should be ok. If not firmware/printer is probably not configured correctly.

    So next would be to check the generated g-code on z moves. Actually it is not common that nozzle goes up after homing to heat it. On bed it can melt the bed so it is a good thing to lift it until hot and then go down for printing.
  • edited September 2023

    Thank you for your answer!

    I found the solution. The homing system works so when the "wagon" touches a button, it knows its position is 0.

    The thing is, the printer set the position Z on 0 when the button is pushed.
    Slic3r set the position Z on 0 when the button is released.

    I just had to ajust the screw that pushed the so called button... And now it works! Not flowlessly (beginner 101 ^-^'), but i'll learn from there.

    Happy printing!  ;)

    Best regards,

Sign In or Register to comment.