Repetier-Firmware configuration tool

Repetier-Firmware configuration tool doesn't display the window where you can check the printing time and filament printed quantity, but when I upload the firmware at the arduino ide to the motherboard it displays this window at my full graphic smart controller lcd,strange!


  • I don't see the connection between showing printing time/filament usage and configuration tool. If you have eeprom enabled, you get this feature. If you also have a lcd you get that page to view usage. Since these values are usage counters, they start with 0 and continue to count, also you can change them over eeprom editor.
  • Greeting,

    Is there's any method to reset the "Printing time?"

    I've tried so many times
     uploaded firmware with different EEPROM MODE each time,
     still can't get it work ...

    I just found that "Filament printed" can be reset or set to any value I wanted,
    by using Repetier-Host --> [Config] --> [Firmware EEPROM confirguration]
    It would open a new window which allows me to change the settings ...
    There the second line "Fliament printed [m]" <-- I can change it to 0. That's great!

    But I can't find where to change or reset the "printing time" in this  Firmware EEPROM settings window.

    Tried to update Repetier-Firmware with EEPROM MODE changed <-- not working.
    The  "Printing time" remain the same on the LCD screen as home the page#4.

    Is there any way to do this?
    I just want to rest the "Printing time" back to 0.

    Think you.

  • Haha ^o^ ... I've just found it!!

    It's just right after the next line of the "Fliament printed [m]"
     with different name "Printer active (s)" <-- I change to 0. And it works!!

    Printing time is now shows "0 Days 0:00"

    I am I'm curious, and really want to learn more ...
    Is there some how I can do it by LCD menu?
    Or is there a gcode command that I can use,
     then everytime when the printer starting to print a new thing I can have them reset to 0, automaticly.

    Thank you.

  • That counter was not meant to be reset. It is more a total counter to see how much printing you have done in total. Latest 0.92.3 show also filament used by last print.

    The only commands to reset it are the M206 commands which set 0 to eeprom. Open log and activate commands. Then enter 0 and 0 and see which commands get send. Remove Nxxx and checksum and you have your command.
  • Thank you very much!  \^o^/

    I knwe the idea is a total counter.
    I just wanted to see how much time and how long the filament used each time printed something out.
    And a thought that if I can set both of them to 0 everytime beging to print an object.
    Then I should can know that the usage of the printing time and filament used.

  • It works! ^o^
  • Hallo, ik ben bezig om mijn k8200 aan de praat te krijgen, maar ik stoot op een paar problemen ten eerste staat mijn verwarmd bed op 837,25 graden[beetje warm] maar ik kan mijn x y en z assen niet bedienen handmatig,haal ik de 2 polige stekker naast de reset knop los en ik reset de boel dan kan ik de x en de z as bedienen , als ik nu de home knop bedien dan gaan de x en de z as naar positie, de y as gaat bij meerdere keren proberen alleen naar voren hij keert niet terug,wie o wie weet wat ik verkeerd doe,heb verschillende opties geprobeerd, heb er behoorlijk wat uurtjes inzitten zonder resultaat,wie heeft de oplossing voor
  • Would easier to understand in a language I speak better.

    Wrong temperature ist often a wrong thermistor table.

    y homing can be caused be a triggering end stop. Check M119 output if it is high while not triggered. Then it's wrongly configured.

    The rest I did not understand.
  • in welke taal kan ik jou beter benaderen?
  • English because it is the official language of this forum so everyone can understand and help.
  • For ocinlaw:
    Hello, I am trying to get my k8200 to work, but I encounter a few problems at first, my heated bed at 837.25 degrees [little hot] but I can my xy and z axes not operate manually, I get 2 pin connector next to the reset button and I reset things I can control the x and z axis, as I now the home button keypad then the x and z axis move to position, the y axis is at multiple times just try it forward does not return, o those who know what I'm doing wrong, tried different options, there have a lot of hours in it without result, which has the solution for

Sign In or Register to comment.