Dualhead temperature control - offset until switching heads for first time

I'm labelling this as a bug but it may be something else.

I have a dual head printer in beta test
Controller is a Megatronics V2
Firmware is Repetier 0.91
Host is Rep 1.05

Symptoms are:

1) Starting from a freshly powered up cold system, bed and both extruders measure ambient temperature, all within +/- 0.5C. Turn both heads on, first extr 1 and a second later extr 2, both with a setpoint of 225C

2) Track temperatures in Reptier Host (RH), extruder 1 selected and shown on temperature curve, both extruders monitored on bar graphs,   do not switch selected extruder in RH
manual control panel, E1 settles at 225C and E2 at 211C as seen on the bar graphs,  but both heads
are at around 225-230 as measured with an external reference t/c.

3) Now switch heads in RH, so E2 is selected, the RH temperature curve now shows the
temperature as being low and the system immediately reacts and brings
E2 up to 225C and both extruders settle at 225C as indicated on the bar graphs- except if you check with an
external t/c it is actually more like 235-240C

4) In RH now switch back to E1 and both extruders stay at indicated 225C

Any suggestions, any further info I can supply to help troubleshoot ?



  • ... probably wasn't clear, in bullet 3 (after switching extruders in RH), both extruders show as 225C on the bar graphs, E1 is at 225/230 and E2 is now at 235/240C
  • First the simple part. Temperatures always differ from external measurements. This is an error prone process. It depends on the place you measure, the contact of sensor to heat block, resistance error of sensor, measurement error of the Arduino AVR and the 4,7k resistor. And the most important part is that in high temp. ranges a small resistance change has a bigger influence. So with all these error sources, we can only expect to get a close temperature and we are happy that at least the result are stable. So you have to find what temperatures work best with your filament and extruder and this is one of the main reasons you always see temperature ranges and not a best temperature for printing.

    The second part does not sound logical to me. When you set a temperature it is send to the firmware and nothing is done after that. So switching extruder send only T1 or T0 to firmware, but no new temperatures. So I can not see why that changes target temperature. You can also see at the bottom status bar, where you see what the firmware thinks the target temperature is. And at last you can open log and display commands send. Perhaps that can help you to discover what is going on. I tried this with latest 0.92 on my dual extruder and it worked as expected. So please check what command send causes what returned target temperature. As you describe it, firmware changes target temperature on switch, whcih should not happen.
  • Checked again, only command being sent is

    22:38:22.407 : N136 T1 *31

    I agree it doesn't make sense so checked again and got the same signature. Even tried reversing the t/c and heater wiring on my system and it is still the reported extruder 2 that shows this strange effect.

    I guess the next step is to reload the firmware and see if if something changes.

  • You could check firmware resonses in log file, but yes I guess the firmware is sending the strange values and host only display them.
Sign In or Register to comment.