Repetier + Klipper connect manual???

edited December 2022 in General
I am using repetier server.
I recently experienced voron+klipper+mainsail.
The mainsail and Klipper installation manuals made it easy for beginners to follow.
Also, I felt that the klipper was much stronger than Marlin.

However, in UX, no one can follow Repetier.
I want to use Klipper and Repetier together.
Is there a separate manual for installation?

* According to the klipper manual, install klipper via mainsail, fluidd, or octoprint I'm not sure, but it seems I can't install only the klipper firmware.


  • If you have a working klipper copy the klipper configuration and all included files to oyur pc.

    Use our pi image and select wizard installation, select klipper as firmware and then tell server to install klipper. Then you have a unconfigured but working klipper. Select klipper from printer menu und copy your printer config and you are done if you choosed same klipper version for install. Otherwise you might need to install firmware stub on voron board, but in the klipper page you can compile that easily. In manual is a klipper entry with more details. Assuming latest server version which has best klipper support.
  • I am a beginner. I really don't know how to connect.
  • Did you read in
    the chapter Advanced Themes->Klipper
    which shows installation details. But you also need to know how to write klipper configuration file. We only describe installation, the konfiguration of klipper config is described on klipper homepage.

    I you have a detailed question let me know where exactly you have a problem with understanding.
  • I proceeded according to the manual.
    * For testing purposes, proceed with the SKR mini e3 v3.0 motherboard.
    * I can configure it. because, I have already experienced configuration through mainsail. (Voron 3D printer)

    1. As in the manual, in [Printer configuration wizard], select klipper for firmware and install it.
    2. Go back to klipper configuration and select build micro-controller.
    3. After setting the klipper firmware configuration according to the value of the main board, press Q to exit.
    Mini e3 V3.0: STM32G0B1 + 8 MHz crystal + 8Kib bootloader
    (E3 motherboard sometimes GPIO as !PA14. However, it is not possible to connect with repetier regardless of whether or not.)
    4. Select download micro-controller file
    5. Rename the downloaded file to firmware.bin and save it to the SD card.
    6. Printer power off
    7. Insert the SD card into the main board.
    8. Printer power on
    9. Unable to connect.
  • edited December 2022
    Is there something I need to fix through the terminal?
  • First understand that here you have 3 components that all need to work:
    1. Printer with board
    2. Klipper
    3. Repetier-Server 

    So you need to figure out which component is making troubles. On server side if you see a green link you are talking with the klipper and know it is not 3. You might see a yellow warning icon next to green link. Click it and you get more information why it failed on 1-2. In newer versions you can also select to show end of klipper log to see if there is something.

    I think uploading firmware it self worked so far when you downloaded the generated bin file. That is how I update my skr e3 mini as well.

    Now thinks often get wrong:
    - Wrong serial port in klipper configuration
    - Includes in printer configuration. The folder the config is stored has no configs and mainsail might have some extra files you included. Replace include with content or hit save as for your config to add a new file to folder, name it as your include file and put content in it, then you can include it as well.
    - Some other config errors, but when it worked on mainsail I think it is one of first two here.

  • Thank you for your help. I'll try again.
  • edited December 2022
    Thank you. I've solved the problem.
    The skr mini e3 v3.0 board was not connected.
    In other words, V0 seems to be unable to connect yet.
    but,octopus pro v1.0 has no problem connecting.
    During the configuration process, 
    the mini e3 board has an additional process for connection unlike other boards. 
    This seems to be a problem with repetier.
  • Now, A warning message "printer is not ready" has occurred. Unlike marlin, interworking with Repetier and klipper is very difficult.  :(
  • Yes, it is more difficult since we now have  Repetier-Server <-> Klipper <-> Printer board.

    Sounds like server-Klipper connection is working good now, but klipper->Printer board is the problem now. Did you already upload the klipper firmware stub to the mini? If so the issue is a bad klipper configuration which is the equivalent of the marlin config.h file. See klipper log end in server for more informations where your exact problem lies. Save and install will restart klipper with new config file and generates new log entries. Maybe it is just the serial name you enter in the config that is wrong. If you have only one printer connected you see it with
    ls -l /dev/serial/by-id
    and you enter /dev/serial/by-id/<name from ls>

    that should make klipper connect with board at least.
  • It worked when I deleted the code (ADXL) used in Mainsail.
    [mcu rpi]
    serial: /tmp/klipper_host_mcu
    cs_pin: rpi:None
    accel_chip: adxl345
    and, All octopus pro have no problem connecting, but mini e3 can't connect. But, it's okay :)
    I am using simplify3d .
    simplify3d can only be given start gcode and end gcode.
    And, the pause or cancel (abort) code was saved in mainsail.cfg.
    (In the past, I used marlin and there was no problem with repetier because it can be freely changed to pause or cancel)
    However, repetier(+klipper) will throw an error if you save the pause or cancel code to the configuration.
    Is there any way?
  • mainsail.cfg is nothing you can reuse in  Repetier-Server - that is configuration for mainsail gui.

    adxl works but you need to install input shaping or the pi klipper service for it does not run.

    What is this pause/cancel code? We have gcodes in printer configuration in case you mean regular gcode commands.
Sign In or Register to comment.