ticking sounds

edited December 2022 in Motor Control
Could you please help me explain what this sound is. I'm having trouble searching for answers so I posted a video of what the machine is doing. I've tried different configurations like
CHOPPER_TIMING_DEFAULT_24V, CHOPPER_TIMING_PRUSAMK3_24V, stealth mode false, and turning off stall detection with -128.
 (STEPPER_TMC5160_SW_SPI(XMotor, IOX1Step, IOX1Dir, IOX1Enable, MOSI_PIN, MISO_PIN, SCK_PIN, ORIG_X_CS_PIN, 0.075, 1, 32, 900, false, 100, -128, 12500000, endstopNone, endstopNone))

uncommenting this also had no effect //#define IGNORE_TMC5160_FEEDBACK

but the ticking remains.


  • Where did you get IGNORE_TMC5160_FEEDBACK from? It was not programmed and hence had no effect. I have now added it to latest commit so it should now help.
  • I was just guessing. After trying the latest commit its still the same. Just the Z axis making the sound in HW but all axis doing it in SW.
  • This define disables testing every 500ms the state. It is the only motor realted test with that frequency and sound seems to be at 2hz around. Only thing is, it always tries to init driver if it did not yet succeed. So does M122 show that the motor is initialized correctly with your values?

    Here the code from 500ms timer:
    template <class stepCls, class dirCls, class enableCls, uint32_t fclk>
    void TMCStepper5160Driver<stepCls, dirCls, enableCls, fclk>::timer500ms() {
    if (!initSucceded) {
    #ifndef IGNORE_TMC5160_FEEDBACK

    you can try to move the #igndef before the iniSucceeded just to test if it is coming from this. If so question would be why it does not initialize correctly then.

  • Das sieht nicht eingeschaltet aus. Ist da schon der Hauptstrom an? Ohne 12/24V funktionieren die Treiber meine ich nicht richtig.
  • I'm confused by this as well. The machine is printing and I have control over the current and other parameters in eeprom. Yet M122 shows that there is no power.
Sign In or Register to comment.