Autolevel height problem

Home for Z axis is 216mm from the bed. The Z axis moves the correct measured distances.
When I run/press the @autolevelbutton (G32 S2), the Z height 228 gets stored in eeprom. Even though 216.181 shows up in the console. I can't figure out where this extra 12 mm is coming from.


  • > ven though 216.181 shows up in the console. 
    Where does it show up? Are you leveling at that height or at lower z? Best is if you can show the firmware output.
    For computing Z it measures current z height, distance to top, z probe height and depending on probe type also a parameter cover height or similar to correct depending on material on bed you do not register (for magnets mesuring distance to metal not plate top). Check eeprom values if one of them comes close to your error.

    Also check z probe height to be correct. Take a cylinder of known diameter, measure z and correct z to diameter height and see if it just fits below nozzle at that position.
Sign In or Register to comment.