LoadLibrary failed with error 1114: A dynamic link library (DLL) initialization routine failed

Any idea what library could that be?

When starting repetier host I see welcome banner and then error message "LoadLibrary failed with error 1114: A dynamic link library (DLL) initialization routine failed" and nothing more.

Unfortunately some programmer forgot to write name of that DLL library in this error message.

Any idea what that library could be? (so I will be able to reinstall it).

Unfortunately reinstalling repetier host doesn't solve this issue.


  • Is there a detailed view showing where that error occurs? 
    What windows version do you use?
  • Windows 10.

    Anyway the problem was in Intel driver. Reinstalling these to different version fixed the problem.

    Apparently some switchable drivers can cause such mess (and my laptop has switchable graphics).
  • Hi, I've got the same issue, but my Intel HD Graphics 3000 is up-to-date (currently at version What driver should I install?
    Thanks for help
  • I've tried various drivers and finally one worked (from dell site I think, even if my laptop is thinkpad). That required forcing using these other drivers and sometimes even forcing windows to accept unsigned drivers (since I had to modify *.inf file, so windows 10 accepted non-win10 drivers).

    So... cannot really help with specifics :(
  • I am also facing the same issue, i downloaded the latest version of repetier host and am using windows 10 OS.
    Any ideas how to fix this??
    All my drivers are up to date
  • I just cleared install dir and reinstalled and all dll files were there, so the missing dll seems to be part of the normal windows/.net setup.

    You could check in windows events if there is a hint which dll is missing. From the timing I think OpenTK wanted to open then opengl library and failed doing that. Thats why @arekm succeded finally.
  • I am also having the same issue. I sort of understand the library idea but not well enough to fix anything in that way. 

    Has anyone come up with a better solution than rolling back drivers until something happens?
  • I checked the windows event logs but couldnt find anything. Any idea which is the dll file that could be missing here
  • If you weren't brave enough for the different drivers and you can live with the older software, I downgraded to Repetier Host V1.0.6 and it opens without issue. 
  • I disabled 3D Acceleration in setting/display and it fixed
  • Same problem.  V1.6.0 worked fine and like a fool I upgraded to V1.6.1

    Now I get the meaningless error 1114 (DLL).

    You broke your software.  Please fix it.

    (Windows 10)
  • Okay, so the problem is an INSTALLATION problem.  

    V1.6.0 worked fine before and after my Win10 upgrade.
    V1.6.1 failed when I installed it.  DLL error when you run it.
    So uninstall and go back.
    V1.6.0 now also fails after install.  DLL error when you run it.

    So it is a Win10 Install problem.
  • Have you tried running as admin in cmd.exe
    sfc /scannow

    to check windows inegrity.Does windows event system tell whcih dll causes the problem? Just installed host 1.6.1 on Windows 10 and it worked from the start, so in general it works but on your system something prevents success.
  • Hello all,

    Easiest way to solve windows 10 and Repetier 1.6.1:
    Change your Display settings in Control Panel / Power Setting / Display

    In my laptop now is Repetier is working well.

  • edited May 2017
    That works!

  • edited September 2017
    Hello, if you have a switchable graphics select repetier-host  to work with Maximun perfomance in app.
    right mouse on desktop, open switchable graphics ,search repetier.exe and select this to maximun perfomance.
    problem resolved with repetier 1.6, 1.61 and 2.05

  • This video on youtube help me to fix it: 

Sign In or Register to comment.