"MAXTEMP triggered" but Extruder at 0 degrees.

edited November 2 in Extruder & Bed
Two Disclaimers:
A: The "Maxtemp"-issue isn't the only problem/symptom, just a part of the problem. I just thought it might be a relevant symptom for the title of the discussion.
B: This is an old and partially modified (not by me, but a friend who knows this kinda stuff but sadly doesn't remember what/how exactly he modified) Print Rite DIY 3D printer I am talking about. So I understand that it is probably pretty hard to pinpoint any problem.

TL;DR: Took out addon to Hotend-thermistor because of loose contacts/temp fluctuations. After that (and installing original thermistor):
  • Both heating elements can't be activated
  • Hotend-Temp is shown to be 0° consistently (Bed Temp seems to work)
  • Errors: "Temperature is reset. Set it before restarting" and "MAXTEMP triggered"
  • Homing works, controlling/moving any axis doesn't.

The road so far: 
I had problems with fluctuating temperature readouts due to a loose contact [on an arduino-board that was added to the printer to be able to use a different Thermistor than the one that came with it (apparantly an NTC 100K)]. After trying to fix the contacts (as I had to do several times in the past), Repetier either said, that the Hot end was at 0°, or somewhere between 500 and 2000°. Since I didn't find the issue and the problem with fluctuating temps seemed to become more frequent anyways, I asked said friend if I could take that entire addon out and go "back to the roots" with a NTC 100K thermistor. Said friend told me that it shouldn't be an issue and the reason he added the board in the first place was because he couldn't find the original thermistor anywhere.
So I got to researching, dug up that the printer needs the aforementioned thermistor, purchased it (this one, to be precise: https://www.amazon.de/gp/product/B09HMCP5NW/ref=ppx_yo_dt_b_asin_title_o02_s00?ie=UTF8&psc=1) and took out the addon.
The Board was only connected to the Power Supply in parralel and obviously to the thermistor and it's output-port on the MB.
So in theory, I should have been able to just take out the board and connect a thermistor directly, instead.

The current problem: 
Sadly, it now seems that Repetier doesn't recognize anything on my printer that has to do with temperature control:
Connecting works, it lists my Extruder and my heated bed (and reads out a seemingly normal temp for the bed at around 20°) and homing also works like a charm. But the Hotend-Temp is always at 0°, and as soon as I try to move an axis, it says "Printer stopped due to errors. Fix the error and use M999 to restart. (Temperature is reset. Set it before restarting)." and doesn't move, no matter which axis I try to control. It then also says "Extruder switched off. MAXTEMP triggered.", even though the temperature never changes from 0°. 
Furthermore, I can't heat up the Hotend OR Bed. Repetier doesn't seem to notice anything wrong when clicking on the Extruder- or Bed-Icon to heat them up, but neither actually get hot, and the indicator LED on the heated bed stays off, as well. Obviously this could mean that the heating elements are broken, but it is a weird coincidence for both of them not to work, imo. Also, in my experience, Repetier doesn't even recognize the heated bed if there is a connectivity problem anywhere in it's circuit. 

I also don't see any obviously broken or disconnected cables, and since everything worked until the aforementioned loose contact, and I think I was careful enough while disconnecting the Arduino-board, there shouldn't be a loose connection as far as I am aware. 

Again, I get that it is hard to diagnose problems this way (especially since the printer is modified), but I still would appreciate any and all help I can get. 



If it helps, here is the Log from Repetier after connecting the printer, homing it and trying to move an axis:
19:18:38.234   No start signal detected - forcing start
19:18:38.250  N1 M110*34
19:18:38.250  N2 M115*36
19:18:38.250  N3 M105*36
19:18:38.250  N4 M114*35
19:18:38.297  N5 M111 S6*98
19:18:38.297  N6 T0*60
19:18:38.297  N7 M20*22
19:18:38.297  N8 M220 S100*105
19:18:38.297  N9 M221 S100*105
19:18:38.297  N10 M80*42
19:18:38.297  FIRMWARE_NAME:Marlin V1; Sprinter/grbl mashup for gen 6 FIRMWARE_URL:http://www.mendel-parts.com PROTOCOL_Version:1.0 MACHINE_TYPE:Mendel EXTRUDER_COUNT:1
19:18:38.297  N11 M111 S6*87
19:18:38.359  X: 0.000Y:0.000Z:0.000E:0.000 Count X:0.000Y:0.000Z:0.000
19:18:38.359  echo:Active Extruder: 0
19:18:38.359  N12 T0*9
19:18:38.359  Begin file list
19:18:38.359  End file list

19:20:16.561  N13 G28*33

19:20:21.342  N14 G1 X0 F4800*63
19:20:21.389  Printer stopped due to errors. Fix the error and use M999 to restart!. (Temperature is reset. Set it before restarting)

19:20:23.014  N15 M999*30
19:20:23.014  N1 M110*34
19:20:23.030  Resend: 1
19:20:23.061  Resend: N1 M110*34
19:20:23.061  Error:No Line Number with checksum, Last Line:0
19:20:23.108  Error:0
19:20:23.108  Extruder switched off. MAXTEMP triggered.

Comments

  • You are using Marlin V1 firmware which is nor from us, so can not say much about firmware errors. Guess it at least reads high values causing it to trigge rthe MAXTEMP error.

    You have the temperature filter active so in log it is not visible whch temperatures are measured from firmware. I think when you see it your self it might obviou sthat it comes from firmware. Means if it has same temperatures in M105 response it comes from the printer. This is in most cases a hardware defect especially if same settings worked in the past.
  • So, after activating the Temp readout and sensing M105, Repetier says:

    ok T:-273.1 /273.1 B:18.7 /-273.1 @:0

    Does that narrow it down?
  • It say bed has 18°C but is disabled.

    Extruder measures -273.1°C which I don't believe. So that seems like sensor cable not connected/broken/shorted or sensor defect. Due to all movements the cables might break at some time and no contact makes it measure extereme values.

    What I do not understand is why temperature is set to 273.1 °C When you move our temperature slide (before getting maxtemp error warning) the value should change to a regular value you selected. Reading is

    T:measuredTemp /SetTemp

  • edited November 3
    So I played around with the sliders, but it still says -273.1/-273.1 and 18.7/-273.1 (sorry, I had a typo in my previous post, the set temp value is also negative).

    Does that mean, it is a firmware/conmection issue? Since it doesn't even send the set temp back?

    What also might be interesting: when disconnecting the thermistor, the temp is measured extremely high (sometimes ~4500°, sometimes ~500°). The set temp is still -273.1.
  • Disconnected is same as broken cable so that resistance is high value. So a short is the negative extreme. If you unplug and measure resistance it should then be quite low while it is normally 100k at room temperature (25°C). That would be a good test to test if it is defect.
Sign In or Register to comment.