Filament lässt sich nicht Extridieren

Hi nach langem suchen ohne erfolg habe ich mich dazu entschieden es hier zu versuchen.

zu mienem Problem.

Ich habe an meinen Anycubic Mega X mit standart Marlin drauf einen Raspberry Pi angeschlossen auf dem Repetier läuft.
Nun wollte ich anfangen den Extruder zu Kalibrieren allerdings kann ich kein Filament fördern.
Zwischendurch hat er es gemacht aber dann anstatt den angewählten 100mm nur 5-6mm.
mittlerweile habe ich keine ahnung was das problem sein könnte da ich auch schon damit gedruckt habe.

das steht in der Konsole wenn ich Extrudieren will.

Send:19:56:45.056: @moveRel E100.0000 F30
Send:19:56:45.056: N1187 G1 E161.00 F1800
Send:19:56:45.057: N1188 G1 E211.00 F1800
Send:19:56:45.057: @updatePrinterState
Recv:19:56:45.070: ok (2)

hoffe es hat wer eine lösung für mich.

Comments

  • Sieht aus als ob du den server nutzt nicht host, richtig? Weil das der host thread ist und der kein @moveRel kann.

    Die gesendeten Befehle sind erst mal richtig. Stell erst mal sicher das du nicht dry run aktiviert hast, weil dann soll er auch nicht funktionieren.
    M111 S6
    Dann muss der Extruder eine Mindesttemperatur ehaben, sonst ignoriert marlin extrusionen. Schreibt aber normal "Cold extrusion prevented".
    Check mal in den eeprom Einstellungen wie viele steps per mm der Extrude rmacht. 0 führt zu keinem Move. Normal sind das 80 ode rje nach übersetzung/microsteps auch deutlich mehr. Beschleunigung und maximum speed sollten auch gleich geprüft werden.
    Versuch erst mal nur 10mm zu extrudieren. Es gibt in der Firmware die Möglichkeit die maximale extrusionslänge pro befehl zu begrenzen. Daher auch der split in 2 x 50mm den du im log siehst.

    Dann gibts noch die Physischen Fehler. 
    - Motortreiber kaputt
    - Stecker nicht richtig drin
    - Kabelbruch
    - Düse verstopft/Filament im extruder zu hoch - hier solltest du motorgeräsche beim Drucken hören durch verlorene schritte
    - Bei TMC motortreibern zu wenig strom

    Wenn kein Filament drin ist und nach M84 solltest du den motor bewegen können. Dann aufheizen und bewegen. Jetzt sollte der Motor an sein und bewegen ist deutlich schwerer. Wenn nicht geht der Motor gar nicht erst an.
  • edited October 7
    ja ich benutz den repetier-server, wusste nicht das es da unterschiede gibt.
    ich hab das alles wohl unterschätzt, über pronterface hatte ichs chonmal ein PID-Tuning gemacht, das war allerdings bevor ich den repetier server angeschlossen habe. hatte da auch keine probleme.

    ich gehe von aus es ist eine einstellungssache da ich noch drucken kann ohne probleme.

    Send:14:12:53.873: N5950 M111 S6
    Recv:14:12:53.876: echo:DEBUG:INFO,ERRORS
    Recv:14:12:53.876: ok

    das sagt er mir wenn ich M111 S6 an den drucker sende

    bei M501 sagt er mir das

    wenn ich richtig bin sind die steps bei 90

    Send:14:07:31.679: N5627 M501
    Recv:14:07:31.685: echo:V29 stored settings retrieved (398 bytes)
    Recv:14:07:31.686: echo:Steps per unit:
    Recv:14:07:31.688: echo: M92 X80.00 Y80.00 Z800.00 E90.00
    Recv:14:07:31.688: echo:Maximum feedrates (mm/s):
    Recv:14:07:31.696: echo: M203 X120.00 Y120.00 Z20.00 E0.00
    Recv:14:07:31.696: echo:Maximum Acceleration (mm/s2):
    Recv:14:07:31.696: echo: M201 X400 Y400 Z60 E10000
    Recv:14:07:31.696: echo:Accelerations: P=printing, R=retract and T=travel
    Recv:14:07:31.705: echo: M204 P400.00 R3000.00 T400.00
    Recv:14:07:31.706: echo:Advanced variables: S=Min feedrate (mm/s), T=Min travel feedrate (mm/s), B=minimum segment time (ms), X=maximum XY jerk (mm/s), Z=maximum Z jerk (mm/s), E=maximum E jerk (mm/s)
    Recv:14:07:31.712: echo: M205 S0.00 T0.00 B20000 X4.00 Y4.00 Z0.10 E0.00
    Recv:14:07:31.712: echo:Home offset (mm)
    Recv:14:07:31.712: echo: M206 X0.00 Y0.00 Z0.00
    Recv:14:07:31.712: echo:Z2 Endstop adjustment (mm):
    Recv:14:07:31.712: echo: M666 Z0.00
    Recv:14:07:31.712: echo:Material heatup parameters:
    Recv:14:07:31.713: echo: M145 S0 H180 B70 F0
    Recv:14:07:31.715: M145 S1 H240 B110 F0
    Recv:14:07:31.715: echo:PID settings:
    Recv:14:07:31.717: echo: M301 P20.00 I0.30 D150.00
    Recv:14:07:31.720: echo: M304 P60.00 I0.30 D30.00
    Recv:14:07:31.720: echo:Filament settings: Disabled
    Recv:14:07:31.720: echo: M200 D1.75
    Recv:14:07:31.720: echo: M200 D0
    Recv:14:07:31.720: ok

    ich habe gerade noch über M84 festgestellt das der Extruder nicht angeht, über die direkte bedienung des Druckers kann ich aber filament laden und er extrudiert es auch.
  • kleiner nachtrag es hat sich alles geregelt.
    die E-steps bei 90 waren zu wenig, ich bin bei einem wert von 425 angelangt.
    wenn ich über das bedienfeld 10, 50, oder 100 anwähle kommt nur mist bei raus da er dann auch den vorschub erhört.

    mit G1 E50 F40 konnte ich genau 50mm Extrudieren

    ich hab wohl ausversehen den wert geändert beim rumprobieren mit dem repetier-server

    trotzdem vielen dank.
  • Die vorschubgeschwindigkeit steht in der MItte. Eine ist zu schnell zum Drucken. Die ist zum befüllen von bowden bis man am Druckkopf ankommt. Die langsame ist zum etxrudieren:-)
Sign In or Register to comment.