USB debugging Linux


I've got 2 Printrbots, both of which work fine on my Mac (just not at the same time...) I had a spare pc running linux (Lubuntu 15.10) so I thought I'd try to make it work...

-I installed RepetierHost v1.6.1. It launches fine from desktop or from terminal
-I connected Printrbot to pc via usb and plugged in power. The green light came on the printrbot board.
-I pressed "connect" in RepetierHost and I do not get a connection.
-- I am part of the dialout group
-- I get this error message:
steve@steve-desktop:~$ Opening serial failed on second try:System.IO.IOException: No such file or directory
  at System.IO.Ports.SerialPortStream.ThrowIOException () [0x00000] in <filename unknown>:0 
  at System.IO.Ports.SerialPortStream..ctor (System.String portName, Int32 baudRate, Int32 dataBits, Parity parity, StopBits stopBits, Boolean dtrEnable, Boolean rtsEnable, Handshake handshake, Int32 readTimeout, Int32 writeTimeout, Int32 readBufferSize, Int32 writeBufferSize) [0x00000] in <filename unknown>:0 
  at (wrapper remoting-invoke-with-check) System.IO.Ports.SerialPortStream:.ctor (string,int,int,System.IO.Ports.Parity,System.IO.Ports.StopBits,bool,bool,System.IO.Ports.Handshake,int,int,int,int)
  at System.IO.Ports.SerialPort.Open () [0x00000] in <filename unknown>:0 
  at RepetierHost.model.ProtectedSerialPort.Open () [0x00000] in <filename unknown>:0 
  at (wrapper remoting-invoke-with-check) RepetierHost.model.ProtectedSerialPort:Open ()
  at RepetierHost.connector.SerialConnector.Connect () [0x00000] in <filename unknown>:0 

I've been trying to read about this... Is it a "mono" issue? (mono v4.2.0)

I've tried different cables and usb ports.
The USB ports are individually tested with a mem stick - I can xfer data to/from stick on all ports.
Cables individually tested  and work for Printrbot/Mac connection.

How can I get rH to see my printrbot? 

Thank you




  •  Opening serial failed on second try:System.IO.IOException: No such file or directory

    means the port is not available or written wrong. What did you use as port name? Must be something like /dev/..
  • SOLVED -

    First, I verified new connection was dev/ttyACM0
    Then, per suggestion from
    Try going into System / Users and Groups and checking the box on your username in the TTY Group.

    This allowed ttyACM0 to show in RepetierHost. Once this was selected, I was able to connect and control machine.

    Thank you


Sign In or Register to comment.