Slic3r registration error

I downloaded and used the latest version of Repetier-Host, with Slic3r, 1.0.6, and today went to print 2 copies of a pad in one go, with no skirt and 3mm brim; the first brim printed out fine, but when it went to print the 2nd, it went to the X home position of the bed, printed a line from the 2nd part, then went to finish printing the brim of the 2nd part, only it was shifted about +3mm X further from where it was supposed to be.  I tried separating the parts more and moving them around the bed, but it does the same thing.  When I let it run with the shift, it went back to the 1st part for the infill and it was then shifted the same amount.  What's up?  Using an Airwolf 3D 5.5.  All previous versions have never had this problem.


  • Not totally sure it is slic3r though, because the preview in Repetier-Host shows the pads in the correct spots; which kind of suggests that RH is sending the wrong command out maybe?
  • I just tried starting 2 smaller pads, about a 2" x 3" total area on the print bed, and they are processing fine, but the larger pads, about a 4" x 6" area messed up, even when I separated the pads into 2 distinct areas, not connected in any way.

  • So I did some checking and it looks like the problem lies in these negative coordinates Slic3r
    G1 X18.810 Y56.385 F9000.000
    G1 X-0.308 Y55.498 F9000.000
    G1 X-2.360 Y91.996 F9000.000
    G1 X-0.859 Y110.495 F9000.000
    G1 X57.716 Y138.226 F9000.000
    G1 E1.20000 F1800.000
    G1 X149.172 Y138.226 E1.84470 F3600.000

    why does Repetier Host show the printout as normal, it should throw out
    an error warning or something when coordinates outside the print area
    are used, shouldn't it?

  • edited November 2014
    So after some more checks, I found that when I place 2 individual pads with the same orientation, the problem occurs, but when I save the pads to a new STL and just load the single STL and slice, it doesn't create the issue.  I also tried loading the 2 individual pads into the actual Slic3r program I downloaded from the manufacturer's website, and it sliced it correctly with the same settings, so it looks like an implementation bug in the Repetier Host version of Slic3r.
Sign In or Register to comment.