Filament Change issue with new Repetier Server version

We have detected that, in versions after 1.3.0, when making a filament change, the printer stops receiving commands.

Specifically, after unloading the filament, the nozzle temperature drops. When attempting to do a reheat, the printer ignores it, as well as any other commands sent to it, until it is rebooted.

As I said, until version 1.3.0 it worked perfectly.

Please tell me if you need more info to determine the cause.

Thanks a lot,


  • Check in console in parallal if you get a error message from printer.
    Also note that current release has a bug that extrusions longer 50mm get longer. Will be fixed in 1.4.9 but might therefore exceed max. extrusion length and it depends on firmware if such moves are ignored or if they stopp until reset. You should see tyhis in console if it happens.
  • Thanks for the quick response.

    It doesn't seem that the max. extrusion length is the issue. This is our firmware (Marlin):
    #define EXTRUDE_MAXLENGTH 30000

    And this is our console output at the time of the problem:

    If I'm not mistaken, we're not getting any error message from the printer.

    Thanks again!
  • Printer is asking for dialogs and wait for M876 S0 to continue. So you are using the printer internal filament change function. You should see similar informations on the printer display. In  Repetier-Server you should have seen a dialog box appearing. Did you? The problem is that communication is blocked due to the dialog and only emergency commands can be send like mentioned M876. If there follow too many emergency responses the buffer of printer is full and you can not continue from any host and must answer on the printer display to finish the filament change. 

    Biggest problem is when you don't have a printer display attached. Then you should limit dialog to 2-3 answers. Problem is that this dialog is easy to exceed the limit if you need to purge several times for example.
  • Yeah I see the usual dialog boxes in Repetier-Server (UI and TouchScreen). Everything is the same as usual, only difference is the printer stops responding after the filament unload process (only with versions after 1.3.0).
  • Ah yes, you are right. If you have a newer pi image you can use dev version
    in ssh terminal to install it. There is a bug that prevents bypassing emergency commands for some blocking conditionals and slow commands. That might be the reason you also can not send M876 which is one of the emergency commands.
  • Done! I've installed the dev version (1.4.9) and it works just fine.

    So, the problem is solved, thank you very much.
Sign In or Register to comment.