Raspberry Pi WiFi connection issues solved by manually setting gateway

Hi folks, just wanted to share a tip that I only stumbled upon after several hours of frustration, in the hope that it saves someone else the same.

I was having all sorts of issues with the wifi connection on my RPi only connecting briefly before being lost. I tried everything I could find in the docs and nothing helped until I stumbled upon a related thread on the Raspberry Pi forum where someone mentioned setting the gateway manually to the router IP.

Thankfully, it seems to have done the trick. My exact setup is that the router is set to provide a fixed IP to the Pi's MAC address and I have also told Repetier-Server to use the same IP under "Additional Address". 

All this may seem obvious to more seasoned folks but maybe not so much to a casual or new user, so I figured it was worth mentioning. Cheers!


  • Makes sense. Normally we get everything from DHCP and with the static address you disable DHCP, so need to provide netmask/gateway manually.
  • I'm pretty sure the issue existed before I set up the static IP, maybe some weirdness with my particular router. Maybe it would be useful to amend the help text to make clear that if you're setting a static IP, it is required to also set the gateway? The way it's currently worded makes it seem optional. 
Sign In or Register to comment.